VM Fusion question

Discussion in 'Mac Apps and Mac App Store' started by aries333, Jan 13, 2011.

  1. aries333 macrumors newbie

    Joined:
    Jan 13, 2011
    #1
    I am using VM Fusion on my Mac, and my internet was working fine on the VM Fusion part for a while. Now, all of a sudden, the internet no longer works. It is working fine on my Mac side. Searching the internet for this issue, everyone says go under Virtual Machine and click on Internet/Network to change settings here - but this option doesn't even show for me. I have tried the obvious (rebooting). Any suggestions? Thanks!
     
  2. Coldsmoke macrumors newbie

    Joined:
    Jan 13, 2011
    #2
    Had a similar problem... try this.

    You indicated that you rebooted.... For clarity, did you reboot the VMware environment or the MAC? (Its not wise to reboot the MAC before properly shutting down or suspending VMWare.)
    I would recommend that you go to the menu item "Virtual Machine" then select "Shutdown", then exit VMWare.
    After doing the above restart VMWare but do not start windows yet. Instead select Virtual Machine ---> Network Adapter and confirm it reports that it is connected. At this point you should also be able to view the virtual network card settings and confirm that it is set to share the MAC's network connection or is set to be connected directly to the physical network.

    After confirming the above you can try to restart windows using the Virtual Machine ---> Startup menu and see if the connection works.

    Last, it may be related to the application you are using. As an example, when I use ewallet to sync with my Iphone, it always requires a bridged network connection for some reason which I need to set before starting ewallet. Then after syncing I need to go back and reset the connection to NAT.
    Hope the above helps.
     
  3. CylonGlitch macrumors 68030

    CylonGlitch

    Joined:
    Jul 7, 2009
    Location:
    SoCal
    #3
    From the VMWare window, look at the lower right corner. There is a symbol that looks like this <...> (dots in the middle though) [assuming you are in windowed mode not full screen]. Click on it and select "Disconnect Network Adaptor". Then wait a second for windows to say your network is disabled. Then click it again and select "Bridged <Auto Detect>". That should force it to reconnect to whatever network you are using; BUT sometimes this doesn't always work and you have to tell it specifically what network to connect to; but 99.9% of the time it will connect correctly.

    I found that VMWare sometimes gets lost when you switch, on the fly, from a wired network to a wireless one. I do a lot of network testing and am always reconfiguring things, VM gets lost from time to time.
     
  4. aries333 thread starter macrumors newbie

    Joined:
    Jan 13, 2011
    #4
    Problem fixed

    Thanks for your responses - I had rebooted VM Fusion 1st (then the Mac itself), and that didn't work. But then I was able to "install tools", and then when I rebooted VM Fusion again, the network option was no longer greyed out. Then I could connect again. Not sure why it did this but at least it is working again... Thanks!
     

Share This Page