VMware Fusion, correct setup?

yusukeaoki

macrumors 68030
Original poster
Mar 22, 2011
2,550
6
Tokyo, Japan
Hi guys.

So I forgot to install Bootcamp on my Optibay before I removed my ODD and
dont want to go through the hassle to put it back together.

Now, I got VMware Fusion and loving it so far.

However, I got Total War Shogun 2 from my friend and holy crap it lags.
Considering it running on virtual machine, I set the settings to medium on the game.
Vmware is set to 2 cores, 4088MB of RAM, yet it still lags.

Here is the question. Why does it lag? And what is the best setting to run it?

The RECOMMENDED requirements, not minimum, for the game is:
C2D E7500 2.93GHz vs (Mine is running virtually, 2 Core i7-2720QM 2.2GHz)
Radeon HD 6570 1GB vs (Radeon 6750M 1GB)
4GB vs (Set to 4GB)

Do I need to set up for more RAM?
Im pretty sure the CPU is fine.
But do I need more RAM and/or is it the GPU not able to handle 2 OS running at the same time?

On Win7, Im running Norton and Daemon tool.
Mac OS X, running Littlesnitch, iStat, Geektool, and jumpcut.

Thanks in advance.
 

Nermal

Moderator
Staff member
Dec 7, 2002
18,717
1,200
New Zealand
Virtual machines have a huge overhead when it comes to the video card so you really need to use Boot Camp for gaming. Fusion can use a Boot Camp partition but I'm not sure whether it's possible to go in the other direction (use a VMware image for Boot Camp).
 

yusukeaoki

macrumors 68030
Original poster
Mar 22, 2011
2,550
6
Tokyo, Japan
Virtual machines have a huge overhead when it comes to the video card so you really need to use Boot Camp for gaming. Fusion can use a Boot Camp partition but I'm not sure whether it's possible to go in the other direction (use a VMware image for Boot Camp).
Ah it is the GPU...
I would go Bootcamp but my SSD is 128GB and I only have 70GB left on it so no bootcamp for me :(
 

proximo

macrumors member
Aug 28, 2011
63
0
Try setting the VM to use a single core. In my experience, VMs always run slower if set to use more than one core. The reason is that the VM can only be dispatched if the number of cores configured are free. It's much more common that one core is free than two (or three, etc).

However, I got Total War Shogun 2 from my friend and holy crap it lags. Considering it running on virtual machine, I set the settings to medium on the game.
Vmware is set to 2 cores, 4088MB of RAM, yet it still lags.
 

yusukeaoki

macrumors 68030
Original poster
Mar 22, 2011
2,550
6
Tokyo, Japan
Try setting the VM to use a single core. In my experience, VMs always run slower if set to use more than one core. The reason is that the VM can only be dispatched if the number of cores configured are free. It's much more common that one core is free than two (or three, etc).
Ok, thank you, I'll try it out.
 

nitromac

macrumors 6502
Jul 29, 2012
282
13
US
Are you sure you have the 3D acceleration option enabled? I can run League of Legends at 1680x1050 on medium-high settings at a constant 60fps. Through VMWare.
 

yusukeaoki

macrumors 68030
Original poster
Mar 22, 2011
2,550
6
Tokyo, Japan
Are you sure you have the 3D acceleration option enabled? I can run League of Legends at 1680x1050 on medium-high settings at a constant 60fps. Through VMWare.
Is that setting on the VMware?
Also what is your settings? ex) CPU core, RAM set up, etc?
 

nitromac

macrumors 6502
Jul 29, 2012
282
13
US
Is that setting on the VMware?
Also what is your settings? ex) CPU core, RAM set up, etc?
Yeah, I don't have it installed right now as I just installed an SSD, but it's in the settings for each VM. Just look around and you'll find it.

As for my settings, I dedicated two cores and 4GB of RAM to my Win7 64-bit VM. I don't think I fooled around with any other settings apart from enabling 3D.
 

yusukeaoki

macrumors 68030
Original poster
Mar 22, 2011
2,550
6
Tokyo, Japan
Yeah, I don't have it installed right now as I just installed an SSD, but it's in the settings for each VM. Just look around and you'll find it.

As for my settings, I dedicated two cores and 4GB of RAM to my Win7 64-bit VM. I don't think I fooled around with any other settings apart from enabling 3D.
I just looked around really quick but I couldnt find it.
Maybe I missed but I have to go to work so I will get back with you asap.
Thank you.
 

fingerman

macrumors member
May 21, 2011
76
0
Stockport, UK
Command E or Menu / Virtual Machine / Settings

In there select Processors & Memory and change your settings.

The Virtual Machine cannot be running while you make the changes ;)
 

yusukeaoki

macrumors 68030
Original poster
Mar 22, 2011
2,550
6
Tokyo, Japan
Command E or Menu / Virtual Machine / Settings

In there select Processors & Memory and change your settings.

The Virtual Machine cannot be running while you make the changes ;)
No, we were talking about enabling 3D acceleration.
My CPU and RAM settings are exactly the same as his.
I just cant find the 3D setting on my VMware.
 

yusukeaoki

macrumors 68030
Original poster
Mar 22, 2011
2,550
6
Tokyo, Japan
UPDATE:

As many of you know the release of Fusion 5, I updated and all my apps works like a charm!
The graphic has gone far better compared to the 4th gen.