VMWare Fusion + New Apple KeyBoard's Number Pad

Discussion in 'Mac Apps and Mac App Store' started by Chupa Chupa, Sep 19, 2007.

  1. Chupa Chupa macrumors G5

    Chupa Chupa

    Joined:
    Jul 16, 2002
    #1
    The number pad on the new Apple Keyboard (Aluminum) doesn't work in VMWare Fusion w/ Win XP. Is there a driver somewhere I can d/l to get it to work? It's driving me nuts in Quicken.
     
  2. PhatBoyG macrumors regular

    PhatBoyG

    Joined:
    Jun 8, 2007
    Location:
    Tulsa, OK
    #2

    Mine works fine, make sure you press Clear (NumLock in Windows) to turn on the numeric keys. I use the new Al keyboard with my MacBook Pro and the keypad works without any issues. If you have an MBP, you'll get a nice green glow from your 7/F7 key (can't recall which).
     
  3. ecsk2 macrumors newbie

    Joined:
    Oct 29, 2007
    #3
    I have Mac Pro (not MacBook) and I am having these issues:

    http://communities.vmware.com/thread/96869

    Well I have the EXACT same issue as the second to last poster, mouse and tab works fine but the rest will just stop randomly!
     
  4. dewaz macrumors newbie

    Joined:
    Dec 6, 2008
    #4
    I had the same problem, and found the answer on another forum. What you do is bring up the onscreen keyboard in Windows Vista, and turn on num lock.

    - Start-->All Programs-->Accessories-->Ease of Access-->On-Screen Keyboard.
    - In the on-screen keyboard, click "nlk" in the number pad area.
     
  5. tnsmart macrumors 6502

    Joined:
    Aug 23, 2008
  6. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #6
    Mine works in ubuntu, I have to hit the "clear" button as that's the num lock but overall it works in both windows and ubuntu in fusion.
     
  7. tnsmart macrumors 6502

    Joined:
    Aug 23, 2008
    #7
    Thanks! I didn't know that clear was the num lock button.
     
  8. dyn macrumors 68030

    Joined:
    Aug 8, 2009
    Location:
    .nl
    #8
    That's not a strange thing. The guest OS's don't have the keyboard layout for the Apple keyboard. You don't quite notice it with the USA layout but you do notice it very easily when you have a Dutch layout or something else. It will use the standard USA normal pc layout for the keyboard. This means that keys like clear are mapped to something like numlock because that's what is on that exact same position on a normal pc keyboard. This way you also have things like scroll lock, printscreen, etc.

    If you are running the newest VMware Fusion (2.0.5 or the private beta) you can set some keyboard settings in the Fusion preferences (not the vm settings!). Have you tried this? I have this set to use the OS X keys and since I'm using the keyboard without the numpad I had to define the scroll lock key (I've set that to cmd-F12 btw). Same thing can be done for the mouse (which I disabled since that will do weird things when trying to select multiple items in Linux, Windows, etc.).
     
  9. cabster22 macrumors newbie

    Joined:
    Apr 13, 2010
    #9
    Thanks dewaz, by clicking the num lock in onscreen keyboard it now allows me to use my key pad in windows 7. Cheers a good to the point post!
     
  10. sailmac macrumors 6502

    sailmac

    Joined:
    Jan 15, 2008
    #10
    Thanks a million!!

    Exactly what I needed to know !! :D
     

Share This Page