MP 1,1-5,1 VMWare Fusion or Mac Mojave Issue

Batty4Mac

macrumors newbie
Original poster
Mar 14, 2014
5
0
Canada
Hi Everyone,

I am not entirely sure where this should be posted so my apologies in advance if its in the wrong place.

I not too long ago got cMPs and upgraded them to Mojave. They are used primarily for three different projects and are not my primary unit. Mainly to experiment.

One of the projects is crypto mining. As it stands most miners (w/ use of GPU) are for Windows or Linux. And if any do offer for a Mac its for CPU only, as the claim is they don't support Mac GPUs.
Well neither of the cMPs I have are using a 'Mac' GPU, there is no boot screen. So I am looking at testing some mining applications via VMFusion with Window 10 (Why should everyone else have all the fun?!?! lol) and other projects as well.
(I read a post (not sure which site), they were mining on 1,1 and 3.1 and didn't keep the link arghh).

The known issue is the finding root cause when dealing with a Virtual environment - there are many variable to question. Is it the host system (my case Mac,) the Virtual system (VMFusion) or the guest (Windows) or the application running on Windows or other/unknown.

So before I question the application, best I seek expertise (or hell more experience than my own) on possible root issue.

Issue: Application running in Windows needs to connect to a server (mining pool). After trying to connect to the server, the error I'm receiving is;

RequestError. Error: connect ECONNREFUSED 127.0.0.1:8070.

Is these from the Mac side, and if so how can it be corrected?

Thx
 

axrst

macrumors newbie
Apr 6, 2019
23
3
Greece
The app is trying to connect to your own device (127.0.0.1 at port 8070). It depends on the network settings on the Vmware at first. Look under Virtual Machine -> Settings -> Network Adapter what have you chosen. I suggest trying the "Ethernet" setting and give a separate ip address in your local network (eg. if your mac has 192.168.1.5, set your VM to 192.168.1.6 or similar). Be sure to choose a IP that is not used from another device in your LAN. Also keep the same Subnet Mask as your mac.

Apart from that, check if you have little snitch or similar app and/or any firewall witch prevents the connection to the net (this is in your mac).

Begin with these steps and come back to see if there is another (or the same) problem.
 

Batty4Mac

macrumors newbie
Original poster
Mar 14, 2014
5
0
Canada
Thank for the reply. Sadly the option you are suggesting is not entirely available. I am using VMware Fusion 11 (non Pro) if that makes a difference.
The choices I have under the Network Adapter sub menu are: NAT, Bridged (Autodetect), Host Only.
Under settings sub menu - Network Adapter there are three sub panels on the left;
1) Internet Sharing - Share with my Mac
2) Bridged Networking - Autodetect, Ethernet 1, Wi-Fi, Ethernet 2, Bluetooth Pan
3) Custom - Private to my Mac.

I have tried a variation of Bridged (wi-fi, ethernet) to Custom to see if either choices work but to no avail.
And none of the choices offer the option to modify the VM ip. It links back to the Mac's (host) settings.

Hope Im making sense.
 

nocsi

macrumors newbie
Jul 26, 2019
3
2
Thank for the reply. Sadly the option you are suggesting is not entirely available. I am using VMware Fusion 11 (non Pro) if that makes a difference.
The choices I have under the Network Adapter sub menu are: NAT, Bridged (Autodetect), Host Only.
Under settings sub menu - Network Adapter there are three sub panels on the left;
1) Internet Sharing - Share with my Mac
2) Bridged Networking - Autodetect, Ethernet 1, Wi-Fi, Ethernet 2, Bluetooth Pan
3) Custom - Private to my Mac.

I have tried a variation of Bridged (wi-fi, ethernet) to Custom to see if either choices work but to no avail.
And none of the choices offer the option to modify the VM ip. It links back to the Mac's (host) settings.

Hope Im making sense.
That’s localhost in the context of the VM. It’s not exposing an external port. So bridging and NATing won’t do anything. See if there is a config option to attach the service to your vm interface. Otherwise you can SSH reverse tunnel and expose the port from guest to host