VMWare Fusion running Boot Camp WinXP install?

Discussion in 'MacBook Air' started by airboot, Feb 4, 2008.

  1. airboot macrumors newbie

    Feb 4, 2008
    I installed WinXP using Boot Camp on my MacBook Air. The WinXP install runs fine.

    I then installed VMWare Fusion w/latest 1.1.1 update and tried to run the WinXP Boot Camp partition. However, it failed during the preprocessing Boot Camp partition stage.

    Has anyone else been able to get this to work? Either with XP or Vista?

    Perhaps VMWare Fusion needs an update to be able to run a Boot Camp partition on the MacBook Air?
  2. Magguss macrumors regular

    Jan 29, 2008
    Hi airboot!

    An interesting question in my opinion is whether it is possible to install Windows without the SuperDrive, either via air or via ethernet-dongle? Which method did you use?

  3. airboot thread starter macrumors newbie

    Feb 4, 2008
    Hi Magguss,

    I used the SuperDrive. I needed the SuperDrive for other reasons too, so I didn't try to find an alternative method of installing Windows.
  4. johnlvx macrumors member

    Jan 24, 2008
    I am having the exact same issue with Vista Business. The VMWare Fusion app just crashes and shuts down as soon as you press the play button on the VM. I think the air may have a slightly different version of bootcamp due to its new hardware(chipset and processor are highly suspect in this) and Fusion will need an update from VMWare to correct. I havent tried Parallells. Boot Camp is almost a must with this because of the memory limitation... there are some times that more than 1.5GB will be needed and the only way to get that is Boot Camp/VM hybrid solution.
  5. Krevnik macrumors 68040


    Sep 8, 2003
    Before you give up, try going into the VM settings and disconnecting the CD/DVD drive. Then hit run.

    I had the same issue with VMWare today (not a BootCamp partition, but basically) and it was due to the CD/DVD drive support.
  6. johnlvx macrumors member

    Jan 24, 2008
    I will give the cddrive thing a try. For the record, Parallels works.
  7. johnlvx macrumors member

    Jan 24, 2008

    Bravo! It worked. Thanks Krevnik.
  8. airboot thread starter macrumors newbie

    Feb 4, 2008
    Yes, that fixed it. Thanks Krevnik!

    However, when I did "Install VMWare Tools" it seemed like VMWare crashed. Window and dock icon disappeared. I started VMWare again and the VM was back where it left off - now asking me to restart Windows because new drivers had been installed.

    I restarted but VMWare still thinks that the Tools have not been installed. If I select the Install Tools menu option again nothing happens.

    Another issue I'm having with Boot Camp: sometimes the SuperDrive does not work under WinXP. The slot loading mechanism won't let me insert a disc. If I boot into MacOS X, then boot back into WinXP (using Boot Camp), it starts working. Anyone else seeing this? Is my SuperDrive defective?
  9. seecoolguy macrumors regular


    Nov 28, 2007
    when doing bootcamp, do you loose the ability to snapshot and revert snapshots?
  10. airboot thread starter macrumors newbie

    Feb 4, 2008
    Yes, those features seem to be disabled. The Unity feature is not available either.
  11. johnlvx macrumors member

    Jan 24, 2008
    I actually ditched boot camp and installed XP instead of Vista as a regular virtual machine. It seemed like less trouble. Besides, 1.25GB of ram is plenty for XP, even for windows development which is what I am using it for.

Share This Page