VMWare Fusion, Superdrive won't work

Discussion in 'Windows, Linux & Others on the Mac' started by LostInTheTrees, Dec 31, 2012.

  1. LostInTheTrees macrumors newbie

    Joined:
    Dec 15, 2011
    #1
    I am trying to install a program onto my Win7-64 VM from an old CD. (Machine specs at the end.) To do that I have to get my SuperDrive to mount to the VM and work correctly. I have failed utterly to do this and wasted hours trying.

    When the "Connect to Mac or Windows" dialog box comes up, it says that the bootcamp drivers must be installed before the drive will work in Windows. More about that in a minute.

    When I ignore the bootcamp comment, the CD shows up in Windows, but when I attempt to insert the CD (might be a DVD, not sure, it's a Quicken 2007 disk) it simply will not load into the drive. I know it will load disks when connected to the MAC directly. Is this being caused by the bootcamp issue? Or might it be something else?

    Anyway, I tried to install the "Bootcamp Drivers". When you go to the Apple web site, you find 3.1, 3.2 and 3.3 updates for Bootcamp. Each of these tells you that the previous version must be installed first. (That's about the dumbest decision I have ever seen from Apple.) However, when you look for Bootcamp 3.0, it is nowhere to be found!

    Somewhere (not Apple, Apple is silent on this!!!) suggested that Bootcamp 3.0 could be downloaded using the Bootcamp Assistent. So I did that. (BA would only write the downloaded data to an external disk. Again, extremely dumb.) So I download the stuff to a writable DVD on the SuperDrive. There is nothing on the download that is called Bootcamp 3.0. However, I copy the files to a shared folder and attempt to install what might be Bootcamp 3.0 for the Windows machine. Anything I run there says this software is not designed to run on this machine. Presumably, this is because the Windows machine is a VM and not a bootcamp installation.

    I have also spent a lot of time fiddling with VMWare trying to get it to connect to the SuperDrive with no luck.

    What the heck is the way out of this quagmire? Do I really need Bootcamp drivers in my Windows VM? If so, where do I get Bootcamp 3.0? If not, what is the problem?

    - Bob
    MBPr - 16/256, Mountain Lion fully updated
    VMWare Fusion 5, up to date
    VM is Win7-64 Home Premium, up to date
     
  2. electronEP macrumors newbie

    Joined:
    Mar 9, 2013
    #2
    Superdrive and VWWare Fusion

    I experienced the same problem as you had but here is my way to get around the problem. I remove the Apple Superdrive and plug in a generic external USB CD-DVD drive; and VMWare Fusion recognized and play the media immediately.
    Any external USB CD-DVD drive will work, except Apple Superdrive.

    Regards,

    :apple::)
     
  3. david95966 macrumors newbie

    Joined:
    Dec 11, 2013
    #3
    question for electronEP

    electronEP

    Based on your suggestion, I'm buying a usb dvd drive. How did you remove the superdrive? Meaning, did you physically disable it or did you do it in the OS?

    thanks
     

Share This Page