VMware Fusion: Virtual Machine Location?

Discussion in 'Mac Apps and Mac App Store' started by Mac In School, Mar 26, 2008.

  1. Mac In School macrumors 65816

    Jun 21, 2007
    Wife and I are going to be sharing a laptop soon. I'm going to create two separate logins, so we each have our own stuff in OS X.

    We both need to run Windows XP once in a while, and I don't want two 20 GB XP partitions on the machine. Where is a good place to save the virtual machines so both logins will be able to access them? I was thinking the Applications directory. Good idea, or bad?

  2. Bobbi Flekman macrumors regular

    Jan 14, 2008
    By default virtual machines are stored in the user's home directory. Of course you can copy/move them somewhere else. As I don't wanna be reinstalling the machine over and over again, I installed the VM once and copied it to an external disc. Every once in a while I start the machines there to perform the Windows Update game, but for the rest they're just parked there.

    In other words, you can put the machine anywhere you like as long as users have read/write access to them. I wouldn't put them in /Applications though as I don't see it as a part of the application. Is a document you write part of the word processor?

    Also, VM discs are normally created as resizeable, so creating a machine with a 100 GB hard disc doesn't mean you need 100 GB to use them. When you install stuff on them the disc will grow and grow, and eventually need the 100 GB but that would take time.

    You can create a virtual machine from the BootCamp partition as well, though I have no experience with it. Simple logic would say though that all user's should be able to access it. Simply create a VM that is linked to the BootCamp one, right?
  3. RobColorado macrumors newbie

    Mar 10, 2008
    I have just confronted the same problem. Fusion worked fine from the bootcamp partition on my user account; but it did not even recognize the bootcamp partition under my wife's account.

    I wrote to fusion support and they gave me an elaborate way to "attempt" to fix the problem using the terminal. As a newbie I am unconfortable using terminal and the email did not inspire confidence that it would work.

    I previously read that the vms could be copied. So i tried that last night. So far it has worked fine.

    The folder to copy is located in the library folder (i think--am not at my mac now) and is called Fusion or something like that. I copied the whole folder and placed in the same location under my wife's account. I also changed the permissions on the folder to allow her to read/write (I am not sure if that was necessary--but I did it). If you have trouble finding the folder to copy post again and I will check tonight.
  4. Bunker macrumors member

    Oct 28, 2007
    I created a shared folder and authorize all the 3 users on the Mac for Read/Write access.

    Put the VMWare machine in there.

    Make sure you check the authorization of the VMWare machine.

    Everyone can use the same VMWare machine.
  5. RobColorado macrumors newbie

    Mar 10, 2008
    Bunker -- I have done the same thing with iTunes and iPhoto.

    How do you point Fusion to the single virutal machine?

  6. Bunker macrumors member

    Oct 28, 2007
    Firstly, create the shared folder and set authorization that everyone can read and write.

    Log in using user A:
    - Creating your Virtual Machine, save it to this folder.
    - Update authorization for all the files in this folder to allow everyone to read and write.

    Log in using User B:
    - Run VMWare Fusion.
    - On menu, File --> Open and select the VM machine in the shared folder

    A and B cannot run the same virtual machine simultaneously.
  7. Mac In School thread starter macrumors 65816

    Jun 21, 2007
    Okay, I'm having problems here.

    I'm trying to follow this:


    What I did:

    I installed the machine in the wrong place (of course). Then I moved it to

    Macintosh HD\Users\Shared\Fusion Virtual Machines\

    Then I changed the permissions of the file so "Everyone" and "Read & Write" access. Then I expanded the packet contents, and repeated the process on each of those files.

    When I try to run it from User B's account, I get this:

    "No permission to access this virtual machine.

    Configuration file: /Users/Shared/Fusion Virtual Machines/Windows XP/Home.vmwarevm/Windows XP Home.vmx"

    Any ideas?

    How do I do this?

  8. Mac In School thread starter macrumors 65816

    Jun 21, 2007
    I guess I have it fixed. It didn't do anything when I gave read/write access to "Everyone", but when I entered my wife's login info, it worked fine.

    Strange, but done, so I guess I'm good to go.
  9. Flint Ironstag macrumors 6502a

    Flint Ironstag

    Dec 1, 2013
    Houston, TX USA

    Conventional practice says it goes here.

Share This Page