VMware Fusion with 2 boot camp partitions

Discussion in 'Windows, Linux & Others on the Mac' started by xhale, Sep 11, 2008.

  1. xhale macrumors newbie

    Joined:
    Oct 20, 2006
    #1
    [​IMG]

    I have one physical hard drive I use for boot camp on my Mac Pro but it has 2 partitions on it. One I use for my Windows installation and the other is for Windows data, as you can see above. I can't figure out how to get VMware to mount both partitions on the physical drive.

    Using VMware with my boot camp partition is pointless without access to all my data.

    Can anyone shed some light on how to add the second partition?

    Thanks.
     
  2. Trip.Tucker Guest

    Joined:
    Mar 13, 2008
    #2
    What do you mean mount the second partition? Are you not seeing that in Windows once it has booted up in Fusion?
     
  3. Kevin Quincey macrumors newbie

    Joined:
    Oct 19, 2008
    #3
    RE: VMware Fusion with 2 boot camp partitions

    Hi xhale -

    I'm experiencing the exact same problem and haven't been able to find much of an answer yet but am still hoping and looking. Just to be sure we're talking about the same thing, here's what I'm seeing: I have 3 partitions on my boot drive: Mac OS X, Data (formatted HFS+ now, more on that later), and Windows Vista (formatted NTFS):

    kevin-quinceys-macbook-pro:~ kevinquincey$ diskutil list
    /dev/disk0
    #: TYPE NAME SIZE IDENTIFIER
    0: GUID_partition_scheme *232.9 Gi disk0
    1: EFI 200.0 Mi disk0s1
    2: Apple_HFS Macintosh HD 34.9 Gi disk0s2
    3: Apple_HFS Data 146.2 Gi disk0s3
    4: Microsoft Basic Data WinVista 50.7 Gi disk0s4
    kevin-quinceys-macbook-pro:~ kevinquincey$

    In bootcamp this works perfectly. When I boot to the mac, my user directory and all the important directories (Documents, Music, ...) live on the data disk. In OS X, it's now easy to do this using the "Advanced"" options in the "account" system setting (right-click on your account name when it's unlocked).

    From the Windows Vista side in bootcamp it's also easy to use the "Move" tab of the properties of the correspopnding important folders there. I had originally formatted this data partition as FAT32 because it's a native format both mac and PC OS's can read and write but it's so clunky, I've been very happy with the $50 I spent on MacDrive to be able to use the much more sane HFS+ format there.

    Howeverm when I run VMWare under OS X, the PC environment can see the data disk (in Disk Management) but not mount it. I even tried dismounting it from the mac environment before running VMWare but no luck. I was hoping VMWare or MacDrive would be able to get around this problem. However, I checked both of their forums and so far, nothing. VMWare says this is by design to avoid corruption but it's not very elegant and I'm getting the feeling that Parallels is stronger in this capability from what I'm reading.

    VMWare's recommendation is to use "Shared Folders" but this doesn't work for a couple apps, like quicken, who view that as accessing data across a network, which they don't allow. Plus that really makes a mess of your drive letters since it's very difficult to make D appear identically in the boot-camped windows as it does in the VMWare'd (virtualized) one.

    Sorry I couldn't be the bearer of better news but I'm still holding out hope :).
    Kevin Q.

    PS - If you see any notes that moves this discussion along more elsewhere, can you post the URL's here? I've looked everywhere and have only seen people with this issue but no good solutions offered yet.
     
  4. blaznc macrumors newbie

    Joined:
    Feb 16, 2008

Share This Page