VMWare tools not installing in Windows 98

Discussion in 'Windows, Linux & Others on the Mac' started by Josias, Apr 27, 2007.

  1. Josias macrumors 68000

    Josias

    Joined:
    Mar 10, 2006
    #1
    Hey there
    I just installed Windows 98 SE in the VMWare Fusion Beta (latest update), and it seems to work very well, except the fact, that whenever I ask it to install the tools, no setup windows pops up, as it says there will in the help file. I also tried Google, but noone else seems to have the same problem.

    It really is a big problem, as I can't have a resolution above 640x480 and more than 16 colors, which prevents me from running my retro games like RCT and Theme Hospital.:(
     
  2. nospamboz macrumors regular

    Joined:
    Oct 3, 2006
    #2
    VMWare Tools CD ISO images (which is where the installs come from)
    can be found in:

    /Library/Application\ Support/VMware\ Fusion/isoimages/

    You want "windows.iso". Use the appropriate "Virtual Machine"/"CD-ROM"
    Fusion menu item to map a virtual CD to the ISO. Then VMWare Tools
    CD shows up in Windows Explorer in your VM, and you can start the
    installation by hand.

    These questions are better asked on the VMWare Fusion Beta forum
    at VMWare.

    http://www.vmware.com/products/beta/fusion/
     
  3. Josias thread starter macrumors 68000

    Josias

    Joined:
    Mar 10, 2006
    #3
    Thanks, although my external HDD, which I put the VM on, stopped working. :(

    But i'll just make a new one. They're like 200 MB :p
     
  4. Josias thread starter macrumors 68000

    Josias

    Joined:
    Mar 10, 2006
    #4
    Well, my HDD started working again, but Windows 98 still only recognizes the iso as an audio CD with a 44k file. It doesn't make a difference whether I connect the iso manually, or Fusion does it for me, no bingo.

    I'm gonna try and install it on my internal HDD, as the external HDD is the only problem I can think of, but would it help?
     

    Attached Files:

  5. nospamboz macrumors regular

    Joined:
    Oct 3, 2006
    #5
    Like I said, this sort of thing is best asked on the Fusion Beta forum at VMWare.

    Looking there, I found that Win 98 is not officially supported on Fusion. Also
    another person had the same problem regarding the ISO being thought an
    audio CD. He fixed that by actually burning the ISO to a real CD, then
    mounting the CD in Win 98 and installing manually.
     
  6. BillH atTWGSB macrumors newbie

    Joined:
    Apr 30, 2009
    #6
    Win 98

    im running Win 98 on VMware server 1.0.3, and can't get the drivers for Audio, and have tried VMWare tools reinstall, and other things...:confused:
     
  7. ilsidur macrumors newbie

    Joined:
    Sep 25, 2009
    #7
    To install VMware tools in win98:

    Manually mount the image
    /Library/Application Support/VMware Fusion/isoimages/winpre2k.iso

    If you choose windows.iso it will be recognize as an audio CD. winpre2k.iso works fine.
     
  8. Thorun macrumors newbie

    Joined:
    Sep 7, 2010
    #8
    Solved

    Hi.
    I had the same problem. I figured - if Win98 want to auto-start the CD-rom all the time (and think it's a audio CD-file), I'd had to stop it from auto-loading. So i did.
    Preferences --> media --> Units --> Mediacontroller(something) --> CD-soundunit --> Properties --> "Don't use this unit".

    This stops the unit from playing audio-CD's. And 3 seconds after disabling this unit, VM-tools started to install.
     
  9. Plutoftw macrumors newbie

    Joined:
    Nov 30, 2012
    #9
    I know this is a little old thread, but just wanted to post here for future reference. Btw thanks for posting this, it helped me!

    On Windows 8, I was trying to install Windows 98 on a VM in VMware Player. I did so successfully, and like the OP when I tried installing the VMware Tools for 98, it downloaded but didn't do anything on my computer.

    I believe that this may have been because Windows was actively using the Windows 98 CD, though I'm not sure. Anyways solving the problem for me was very simple once I saw this thread. The steps were to...
    • Start up Windows 98 until you get to the desktop.
    • Click the Player button on the bar at the top, and goto: Removable Devices > CD/DVD (IDE) > Settings...
    • Make sure the checkbox labeled as "Connected" is checked, and the radio bubble labeled as "Use ISO image file:" is filled. Click the browse button, and locate the file "winPre2k.iso" inside of the directory "C:\Program Files (x86)\VMware\VMware Player", or inside of VMware Player's program directory. Click "Open", and "OK" in the settings window and you can now install VMware Tools in your VM!

    I'm sure the instructions wouldn't be much different for macs :D
     

Share This Page