VMWare Windows file associations

Discussion in 'Mac Apps and Mac App Store' started by jasimon9, May 14, 2009.

  1. jasimon9 macrumors regular

    Joined:
    Mar 11, 2009
    #1
    Using VMWare Fusion, my issue is that I have several VMs but the file on the Mac desktop opens in the wrong one, even if that VM is not running and the one I want it open in is running.

    In the "Open with ..." drop down, the "wrong" virtual machine is listed several times (as different renamed versions) but the "correct" VM is not listed. How do I add to the list the correct VM? And for that matter, delete the ones from the "obsolete, wrong VM?"

    I have tried deleting the Windows File Type in the old VM and adding it the right one. That still does not work. When I click on the file on the Mac desktop, the wrong VM starts up and opens the file.
     
  2. madog macrumors 65816

    madog

    Joined:
    Nov 25, 2004
    Location:
    Korova Milkbar
    #2
    There is a specific File Association section in VMWare's settings. Either for the VM itself, or in VMware's general preferences. I have seen it, I have mine turned off, but I'm not at my machine right now to check.
     
  3. jasimon9 thread starter macrumors regular

    Joined:
    Mar 11, 2009
    #3
    I have examined every menu, setting and drill down in VMWare and find nothing for File Associations. I cannot find any reference to the term in searching the help, the VMWare documentation, website, or google for that matter.

    So I sincerely hope you will be able to find this information when you are able to.
     
  4. jasimon9 thread starter macrumors regular

    Joined:
    Mar 11, 2009
    #4
    While I was stopping by the Genius Bar on another matter, I asked about this, and the tech could not come up with an answer.

    Apple's online help says to remove old file associations by removing `/Library/Preferences/com.apple.LaunchServices.plist. I did that a few days ago and it did not help. I mentioned this to the tech and he started looking for other config files, but we did not find anything.

    He suggested maybe using "find" at the terminal to look for a string.
     
  5. jasimon9 thread starter macrumors regular

    Joined:
    Mar 11, 2009
    #5
    In a strange twist, the old file associations that I do not want have disappeared. It seems that it might simply take "a long time" for them to go away after having stopped using a VM and deleting the LaunchServices file. So that takes care of the first part of this issue.

    The second part is that now that the proper associations are shown in "Open With", I'd like it if they worked. They don't start up the application, although the VM comes to the foreground at least.
     
  6. Euko macrumors newbie

    Joined:
    Jan 13, 2011
    #6
    Get rid of obsolete VMware file associations

    1. Switch off App Sharing for every Virtual Machnine in WMware Fusion
    2. Get (Download and install) RCDefaultApp
    3. Use RCDefaultApp's App Tab to localize the mapped virtual machines' App's you want to delete.
    4. Go to that Folder. You may have to use Show Package Contents to get into the .vmwarevm Folder.
    5. Backup the Applications Folder to a Memory Stick.
    6. Remove the Stick (so Finder can't see it anymore)
    7. Delete the ones or all the .app Files in the located Folder (these are just links to Windows apps)
    8. Quit SystemPreferances and Reopen Default Apps to verify that they are gone.
    9. Now your File Association List should be free of unwanted Windows Apps.
     
  7. jasimon9 thread starter macrumors regular

    Joined:
    Mar 11, 2009
    #7
    This problem has not recurred for a very long time. As you can see it has been 20 months since the previous post. I would consider this procedure should it recur.
     

Share This Page