VNC Setup for connecting from XP?

kurtk9

macrumors newbie
Original poster
Oct 29, 2007
9
0
I'm trying to connect to Leopard from my XP machine at work and I haven't been able to get it working thus far. Here's what I've tried:

1) Enabled Screen Sharing from the Sharing system panel.
2) Checked to make sure Screen Sharing is listed as being allowed to go through the Firewall.
3) Downloaded both the free version of RealVNC and UltraVNC.

RealVNC 4.1.2 gives me the following error: "No matching security types"

UltraVNC 1.04 gives me the error: "Incompatible Version"

Has anyone had any success connecting via VNC (w/o ARD installed) from XP? If so, what did they do and what XP VNC client?
 

taeclee99

macrumors 6502a
Jun 4, 2002
824
1
Anywhere but here
I'm trying to connect to Leopard from my XP machine at work and I haven't been able to get it working thus far. Here's what I've tried:

1) Enabled Screen Sharing from the Sharing system panel.
2) Checked to make sure Screen Sharing is listed as being allowed to go through the Firewall.
3) Downloaded both the free version of RealVNC and UltraVNC.

RealVNC 4.1.2 gives me the following error: "No matching security types"

UltraVNC 1.04 gives me the error: "Incompatible Version"

Has anyone had any success connecting via VNC (w/o ARD installed) from XP? If so, what did they do and what XP VNC client?
I use Tight VNC to connect to my mac at home (10.5) from work (XP). I could not get real vnc working either. Also make sure that your router allows port forwarding to ports 5900 and 5901.
 
Comment

kurtk9

macrumors newbie
Original poster
Oct 29, 2007
9
0
I just tried TightVNC and I got the following: "Server did not offer supported security type!"

Did you change any of the default options in TightVNC on the Windows machine? My 10.5 machine actually isn't behind a router, but I do have Screen Sharing able to pass through the Firewall.
 
Comment

pb30

macrumors newbie
Jul 2, 2007
26
0
I just tried this last night. Ended up using Vine Server on OSX and realVNC on windows
 
Comment

blackscooby

macrumors 6502
May 12, 2005
274
0
Cheshire, UK
I just tried this last night. Ended up using Vine Server on OSX and realVNC on windows
Exactly what I use. I tried to get the Apple version working but I couldn't find a VNC client that worked with it.
I've also found that Vine Server on the Mini also hangs when you try and reboot and requires me to force quit. This is a pain when I remotely try and reboot as I loose my connection but the Mini doesn't go down :(
 
Comment

kurtk9

macrumors newbie
Original poster
Oct 29, 2007
9
0
Hmm, so you couldn't get past this security issue either? Is Vine Server 10.5 compatible and free?
 
Comment

l33r0y

macrumors 6502
Aug 7, 2007
288
0
Is Leopard screen sharing based on the VNC protocol or is it Apple propriatory?

If it is the latter, I'm not surprised it you can't connect to a Leopard based Mac using a VNC client *without* adding a VNC server on the Mac as well.
 
Comment

taeclee99

macrumors 6502a
Jun 4, 2002
824
1
Anywhere but here
I just tried TightVNC and I got the following: "Server did not offer supported security type!"

Did you change any of the default options in TightVNC on the Windows machine? My 10.5 machine actually isn't behind a router, but I do have Screen Sharing able to pass through the Firewall.
I did not change any of the settings in Tight VNC. It just works on mine.
 
Comment

taeclee99

macrumors 6502a
Jun 4, 2002
824
1
Anywhere but here
Is Leopard screen sharing based on the VNC protocol or is it Apple propriatory?

If it is the latter, I'm not surprised it you can't connect to a Leopard based Mac using a VNC client *without* adding a VNC server on the Mac as well.
Leopard screen sharing is based on the VNC protocol. It is kinda slow connecting via my windows xp pc from work but it works.
 
Comment

Tracer

macrumors 6502
Jun 20, 2007
271
0
The security issue for me was the fact that I had not setup a password for when I tried to connect to my Mac.

You can set it in System Preferences.

You might have to free up a port too, but I don't think so.

Tracer
 
Comment

JYF

macrumors newbie
May 11, 2007
5
0
France
How to connect to a "screen-shared" Leopard Mac from a Windows XP machine ?...

I've tried many ways to connect to my home Leopard iMac from my work XP machine over the Internet. No success. :(

Has someone managed to do this ? If so, can you detail every step to achieve this ? (Mac preferences to check, XP software to use, etc.)

Tutorial badly needed here ! ;) Thanks a lot for any help...
 
Comment

sebf

macrumors member
Oct 25, 2006
48
0
UK
I've tried many ways to connect to my home Leopard iMac from my work XP machine over the Internet. No success. :(

Has someone managed to do this ? If so, can you detail every step to achieve this ? (Mac preferences to check, XP software to use, etc.)

Tutorial badly needed here ! ;) Thanks a lot for any help...
I found that its just a case of opening the ports (on your internet router/hardware software firewall see: http://portforward.com for details) and setting up a VNC password.

Only problem I have been having is that the new Leopard VNC server doesn't seem to support compression/quality settings so every time I connect over the internet it loads my mac in true color at 1600x1050 res which takes about 2/3 mins just to download the initial screen (let alone trying to control the bloody thing!). I think I might disable the built in VNC as it doesn't seem to support different quality/compression and go back to using Vine VNC server!
 
Comment

huzur

macrumors newbie
Apr 8, 2003
8
0
Vancouver, Canada
I just got RealVNC working

- Turn off Render Cursor Locally
- Set color to full color

and it works. Took a ton of trial and errors playing with different options in RealVNC 4.1.2 to get it to work :)
 
Comment

jgp1231

macrumors newbie
Sep 7, 2007
2
0
I just got RealVNC working

- Turn off Render Cursor Locally
- Set color to full color

and it works. Took a ton of trial and errors playing with different options in RealVNC 4.1.2 to get it to work :)
Thank you very much. That worked for me. I'd been messing with this and was getting nowhere until I found your suggestion.
 
Comment

mgroff

macrumors newbie
May 17, 2008
2
0
I doubt anyone is watching this anymore, but I wanted to thank huzur again for that workaround! I'd wasted a couple of hours on this and was getting nowhere. Huge help!
 
Comment

metavalent

macrumors newbie
Jul 11, 2008
1
0
I'm trying to connect to Leopard from my XP machine at work and I haven't been able to get it working thus far. Here's what I've tried:

1) Enabled Screen Sharing from the Sharing system panel.
2) Checked to make sure Screen Sharing is listed as being allowed to go through the Firewall.
3) Downloaded both the free version of RealVNC and UltraVNC.

RealVNC 4.1.2 gives me the following error: "No matching security types"

UltraVNC 1.04 gives me the error: "Incompatible Version"
People still watching this thread and still having EXACT same issues with both these viewers. :confused:

The mouse cursor workaround that has helped for others has not worked here; at least not on XPSP3. Seems rather annoying to have to install Vine when Leopard advertises that this should work out of the box. Will keep trying and report back if I find another workaround. Thanks for all the work in this group!
 
Comment

manman

macrumors regular
Aug 18, 2008
125
1
I have been able to get both UltraVNC and TightVNC to work using the settings people have given here. My question is- is there a reason it doesn't work with different settings? Setting it to anything other than 'full color' the window just shuts down when you log on. But at full color the connection is INCREDIBLY slow, even from within the same house.

Is there any way to get it to work with the settings for a lower connection speed, or any other way to make it faster?
 
Comment

balt

macrumors newbie
Mar 5, 2009
11
0
Found a solution that works!

Hi all,

I actually registered on this forum just to post this solution. I hope it will make many others happy!

Motivation for going through these hoops:
I needed to access the desktop of an old OSX machine every now and then from a windows VNC client. Details of that machine are:
Dual G5 OSX 10.4 without monitor/keyboard.

Important:

- Remote Desktop had never been enabled before on that machine.
- SSH access however was available.

So how do you turn on Apple Remote Desktop / VNC Server on a machine where it never ran before? That part was easy to find on the net: SSH as an admin user onto the OSX machine. Then execute this command:

Code:
sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart -activate -configure -access -on -users admin -privs -all -restart -agent
Try to connect with your VNC client now. If it works, good, you're done. The above command takes care even of restarting the Remote Desktop Service when the computer is rebooted.

But if you're not so lucky (like I was) and the connection fails with a message like:
- "Server did not offer supported security type" (tightVNC)
- "No matching security types" (realVNC)
- "Incompatible Version" (UltraVNC)

you're stuck. What happened in this case is that the VNC password has never been setup properly. Follow these simple steps while still logged in as admin user to set up a default password ("pass" in our case):

- Switch off RDP:
Code:
sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart -stop
- Go to the Preferences directory:
Code:
cd /Library/Preferences
- edit the following files using vi (if you're not familiar with vi, be very careful to follow the instructions to the iota!):
Code:
sudo vi com.apple.RemoteManagement.plist
Put the following lines into this file (hint: copy them from here rather than typing them). Instruction for vi newbies:
- copy the text below into your clipboard
- set focus to the ssh window
- press the 'i' key. This puts vi into text insert mode
- paste the text. If you're on windows/cygwin, click to top left of the cygwin ssh window -> Edit -> Paste
- press the 'Esc' key
- enter the keystrokes ':wq', colon tells vi you are about to enter a command, w is the command for write, q for quit.


Code:
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd"><plist version="1.0">
<dict>
<key>ARD_AllLocalUsers</key>
<false/>
<key>LoadRemoteManagementMenuExtra</key>
<true/>
<key>ScreenSharingReqPermEnabled</key>
<true/>
<key>VNCLegacyConnectionsEnabled</key>
<true/>
</dict>
</plist>
- edit the file
Code:
sudo vi com.apple.ScreenSharing.launchd
press the 'i' key and type
Code:
enabled
, hit return, 'Esc' and ':wq'

- set the default VNC password to 'pass' by editing this file:
Code:
sudo vi com.apple.VNCSettings.txt
and copy/paste this string (the encoded password) into that file:
Code:
 6755221D8BA8C5E2FF1C39567390ADCA
- Now the files need to have their ownerships and access rights configured properly. Do this by executing the following commands after each other:
Code:
sudo chmod 644 com.apple.RemoteManagement.plist
sudo chown root:admin com.apple.RemoteManagement.plist

sudo chmod 644 com.apple.ScreenSharing.launchd
sudo chown root:admin com.apple.ScreenSharing.launchd

sudo chmod 400 com.apple.VNCSettings.txt
sudo chown root:wheel com.apple.VNCSettings.txt
Now stop and start the Remote Desktop Server, or reboot the machine:

To just restart the Remote Desktop first stop it:
Code:
sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart -stop
Then restart it:
Code:
sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/kickstart -activate -configure -access -on -users admin -privs -all -restart -agent
or, alternatively, reboot the server:

Code:
sudo shutdown -r now
Connect to the server and enter your password we set to "pass" above. Set the password to something else by opening the System Preferences -> Sharing -> Apple Remote Desktop -> Access Privileges and set the password in the "VNC viewers may control the screen with password:" to something else.

:apple:ED

Hope this helped!

Cheers

Balt Indermuehle <balt@inside.net>
 
Comment

prosynk

macrumors newbie
Jun 8, 2009
5
0
Hi all,

I actually registered on this forum just to post this solution. I hope it will make many others happy!


Hope this helped!

Cheers

Balt Indermuehle <balt@inside.net>
ANd I joined this forum to thank you for the first workable answer I've come across since re-installing OS X on my home machine. Got to work today and tried to VNC in, but I continuously got the Security incompatibility problem. I ssh'd in, and your solution worked perfectly.

Thank you!
 
Comment

ick

macrumors newbie
Nov 29, 2009
1
0
Balt, I also just registered here to thank you. I'd been stuck for hours, and your solution worked like a charm.
--Ick
 
Comment

bml104

macrumors newbie
Dec 8, 2009
1
0
Worked Like a Charm

Searched all over for this since upgrading to Snow Leopard. It worked like a charm. However, I did have to use the following command

echo -n enabled > com.apple.ScreenSharing.launchd

before the com.apple.ScreenSharing.launchd would show up.
 
Comment

cFoo

macrumors newbie
Jan 4, 2010
1
0
I'm still stuck. I tried both balt and the cursor methods. Still the same error. "Server did not offer supported security type"

I'm on Snow Leopard (64 bit) and Winblows. I desperately need to access my Mac remotely but Apple is making it nearly impossible. I've searched everywhere! I know it's not my connection because I can VNC into my Ubuntu box without any problem (on a different port).

If anyone has any other idea please chime in! I've been trying this for a week already. It took me less than 5 minutes to get it working on Ubuntu.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.