VNC viewer from Linux to Mac keeps hanging

Discussion in 'Mac OS X Server, Xserve, and Networking' started by jerrry94087, Nov 6, 2010.

  1. jerrry94087 macrumors newbie

    Joined:
    Nov 6, 2010
    #1
    I use vnc-4.1.3 from Linux. When I run vncviewer <ip> it quits right after login. When I run vncviewer -AutoSelect=0 -FullColor <ip> it shows the picture, but it usually freezes very fast after login, or immediately after login. Only few times I was able to use it for half hour.

    My network is gigabit. That same vncviewer is very stable when connected to another linux.

    What could be wrong with connecting to Mac?

    Darwin MacBook.local 10.4.0 Darwin Kernel Version 10.4.0: Fri Apr 23 18:28:53 PDT 2010; root:xnu-1504.7.4~1/RELEASE_I386 i386
     
  2. LPZ, Nov 7, 2010
    Last edited: Nov 7, 2010

    LPZ macrumors 65816

    Joined:
    Jul 11, 2006
    #2
    Which vnc server is running on the Mac?
     
  3. jerrry94087 thread starter macrumors newbie

    Joined:
    Nov 6, 2010
    #3
    The one that is enabled from System Preferences/Sharing/Remote Management
     
  4. mathcolo macrumors 6502a

    Joined:
    Sep 14, 2008
    Location:
    Massachusetts
    #4
  5. devlaam macrumors newbie

    Joined:
    Nov 15, 2010
    #5
    I think that the problem is the clipboard. If you activate vncviewer like this:

    vncviewer -SendClipboard=0 -AcceptClipboard=0 -FullColour -PreferredEncoding=ZRLE <ip>

    freezes should stop. Of course, copy&paste is not possible any more.
     

Share This Page