Vnc with ATV 1G 3.0.2?

Discussion in 'Apple TV and Home Theater' started by Grimmkelly, Jan 19, 2011.

  1. Grimmkelly macrumors newbie

    Jan 19, 2011
    Hey folks,

    has anyone managed to get vnc server working on atv 1g 3.0.2 and connect with viewer via pc or iphone? i've follwed instructions to install vine server, store password and create .plist file in launchdaemons folder, but vnc viwer returns 'connection refused (10061)' error when i try to connect. I've also tried to manually start com.osxvnc service with putty but get the following:

    -bash-2.05b$ sudo service com.osxvnc start
    launchctl: CFURLWriteDataAndPropertiesToResource(/System/Library/LaunchDaemons/com.osxvnc.plist) failed: -10

    Also, I see some people have managed to connect with atvflash. Is this worth getting? is it going to work with my already hacked atv?

    Thanks in advance.
  2. ehurdler macrumors member

    Mar 6, 2004
    I have gotten VNC/Vine working with no issue on my aTV 1G. I do not have the procedure I followed as of now since I am at work. I have that bookmarked at home. I hacked my aTV a few weeks ago again with the free patchstick and got VNC running. Procedure was easy. I also for the heck of it tried aTV Flash last weekend, and that is even easier. It is an option to install, so it takes all the guess work out of it. You would not have to redo your aTV if you used aTV Flash.
  3. ehurdler macrumors member

    Mar 6, 2004
    Give this a try. It is what I tried and worked no problems:
  4. Grimmkelly thread starter macrumors newbie

    Jan 19, 2011
    thank you ehurdler,

    unfortunately i have already tried this approach - given your success i just retried from scratch but still to no avail! what version of vine server are you using? first attempt i used the latest available, this attempt i tried 2.2. I am using real vnc viewer on windows vista and keep getting "connection refused (10061)" error, attempting to connect to both 'appletv.local' and local ip address under settings/general/network in frontrow. am i doing something wrong? I am by no means an expert at these matters (clearly) but I am no dummy either- any help is greatly appreciated!

Share This Page