Voice control activating when running

Discussion in 'iPhone' started by Jimmy2shoes, Aug 22, 2009.

  1. Jimmy2shoes macrumors member

    Joined:
    Jul 27, 2009
    #1
    Hey guys,

    I was wondering if anyone could help me, im really happy with my 3gs, i havent had any problems at all until the last couple of days.
    I tend to run everyday ( i cant really avoid it being a personal trainer and all as much as i would like to sometimes lol), and the last couple of times, i will be running along listning to my music on the iphone with the phone on lock and screen off, when suddenly the voice control kicks in and i get that distinctive beep in my earphones.
    I then have to stop. cancel the voice control, re-lock the phone and run again, however lately this has happened about 7 times in a 30 minsute run which is quite annoying!, i have tried powering the phone on and off then trying again but that doesnt seem to work.
    Am i missing something really obvious? or is there a setting i can use to turn this off?
    thanks
     
  2. dlemmon macrumors regular

    Joined:
    Jun 14, 2009
    Location:
    denver, co
    #2
    try switching to the non standard headphones while working out.

    the only other option is that you are pushing the home button for a few seconds while working out. not sure how to avoid this. it could be the case you are using. try turning it around backward maybe?

    thats all I got
     
  3. Reclaim3r macrumors regular

    Joined:
    Jul 15, 2009
    Location:
    PA
    #3
    I have this happen to me while I listen to music in my car. Whenever I plug in my audio jack, the voice control thing pops up... It's really annoying, and I bet it's even more annoying while on a jog... Anyone know how to fix?
     
  4. daihard macrumors 6502a

    daihard

    Joined:
    Feb 19, 2008
    Location:
    Seattle, WA
    #4
    Go to Settings -> General -> Passcode Lock. Disable Voice Dial. This will prevent Voice Control from kicking in when the screen is locked. (Actually, you will still hear the first VC sound, but it will be followed by something like "Voice Control disabled," and you won't have to do anything.)

    [EDIT] I was not entirely correct. Disabling that setting will prevent voice commands from being processed, but the initial Voice Control screen will still show up waiting for you to say something. Doh!
     
  5. Jimmy2shoes thread starter macrumors member

    Joined:
    Jul 27, 2009
    #5
    yeah i did wonder if it was something to do with using the headphones that come with the iphone, annoyingly i just moved house so havent come across my other ones yet!
    It does get irritating though, and i have tried putting my phone in my pocket pretty much every angle you can imagine but it still does it, unless it picks up background noise and thinks im trying to get it to do something?? im not sure, i hope it goes away though!


    I just read the above about disabling it while running, i will give that a try when i go for a run in the next hour and let you know how it works, thanks!!!
     

Share This Page