Voicemail annoying problem

Discussion in 'iPhone Tips, Help and Troubleshooting' started by elpicara, Mar 12, 2009.

  1. elpicara macrumors newbie

    Joined:
    Mar 12, 2009
    #1
    I've been having a problem with my voicemail. Every time I click on the voicemail icon, it'll lit up as if I had clicked on it but it won't dial the voicemail service. Any suggestions on how to fix this.

    My iphone:
    1st generation 8GB
    Unlocked 1.1.4 on the Fido network.
    Visual voicemail never worked but the voicemail used to work fine 3 days ago.

    What I've tried.
    They have reseted my voicemail from the network but that didn't work.
    Tried hard rebooting several times.
    My voicemail works from any other phone.
    Edge works fine.

    Any help greatly appreciate it!!!
     
  2. DPA macrumors 65816

    DPA

    #2
    Does it do to the Visual Voicemail page and say Visual Voicemail is not available, tap here to call voicemail, or something like that?

    David
     
  3. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #3
    What happens if you dial the actual Fido voicemail number from your phone (eg I can press the voicemail button, or dial 901 for O2 voicemail). Does that connect you then? If so then a restore may be what you need, as the button's settings may have got corrupted.

    (PS I stuck with 1.1.4 for many months, but recently bit the bullet to go to 2.2 and I'm really pleased, it's got a lot of improvements. Mine's also an unlocked 2G.)
     

Share This Page