Voicemail not Available on my 3g?

Discussion in 'iPhone' started by Stangs55, Jul 12, 2008.

  1. Stangs55 macrumors 6502a

    Stangs55

    Joined:
    Jul 3, 2007
    Location:
    The Lone Star State
    #1
    Ever since I restored my iPhone backup last night, I cannot get to my voicemail :(

    I can click the voicemail "button" in the phone view and it'll highlight...but it doesn't change from the screen I'm currently on.

    Any ideas?

    I think I'm just going to do a clean wipe...is there a latest firmware download link?
     
  2. Sean7512 macrumors 6502a

    Joined:
    Jun 8, 2005
    #2
    Open the Phone app and dial in your number, then press "Call" Follow the prompts, once you do that, your voicemail will start to show up, you have to activate your voicemail before you can use it ;)
     
  3. fishkorp macrumors 68020

    fishkorp

    Joined:
    Apr 10, 2006
    Location:
    Ellicott City, MD
    #3
    The firmware doing a restore is newer then what ships with the iPhone 3G. You'll still have the voicemail problem. What I did to fix it is to call my own number, it then prompted me for my vm password. After I did that, the vm menu works again.
     
  4. InTheAir macrumors regular

    Joined:
    Jul 11, 2008
    #4
    Thanks for the post.

    I had the same problem--restored my iPhone and then voicemail didn't work anymore.

    I called myself as instructed above, but it never picked up. Once I hung up (without having to enter anything), I received my earlier voicemails (test emails).

    Now it works great.

    Thanks, guys.
     
  5. albeli macrumors 6502

    albeli

    Joined:
    Jun 17, 2008
    Location:
    Here
    #5
    I'm having the same problem. I set up voicemail and called from the landline and my husband's cell to test it out, and when I go to recents there aren't any blue dots to indicate messages. I'll try this and see if it works.

    Hee, I called myself and after I hung up I went to my voicemail again and before I could even do anything my messages just popped up. :)
     
  6. Gizmotoy macrumors 65816

    Gizmotoy

    Joined:
    Nov 6, 2003
    #6
    Just in case anyone else runs into this, I had a variation on this problem. I'd hit the voicemail button and nothing would happen. I tried calling myself as suggested here, and simply got a "Mailbox not set up"-type error with no option to set it up. Restarting the phone did not work.

    I ended up having to call AT&T on another phone, and they sent some kind of reset signal. When I turned the phone back on, it was working again.
     

Share This Page