Volume Buttons not working on Lion

Discussion in 'Mac Pro' started by sdneidich, Jul 20, 2011.

  1. sdneidich, Jul 20, 2011
    Last edited: Jul 20, 2011

    sdneidich macrumors member

    Joined:
    Feb 5, 2011
    Location:
    NC, USA
    #1
    My volume buttons are not working. Press volume up or down, and the volume appears, but does not go up or down. Mute does appear to work.

    Recommendations please? Thanks!

    MBP 2011 i7, 8 GB RAM, 128 gb SSD
     
  2. minifridge1138 macrumors 6502a

    Joined:
    Jun 26, 2010
    #2
    What audio output are you using? Speakers from the line out? USB audio? Optical out?

    When you got to System Preferences -> Sound -> output, what's selected?
     
  3. sdneidich thread starter macrumors member

    Joined:
    Feb 5, 2011
    Location:
    NC, USA
    #3
    I was just using normal speakers on the MBP.

    But it is fixed now. I think it had something to do with "App Tamer," as restarting with it not running fixed the problem.
     
  4. gmladenov04 macrumors newbie

    Joined:
    Jul 19, 2011
    #4
    same thing here. i need to restart in order for the buttons to work
     
  5. derbothaus macrumors 601

    derbothaus

    Joined:
    Jul 17, 2010
    #5
    You need to kill coreaudiod. This will bring back functionality without rebooting. In fact usually a reboot makes them unusable again in my experience.

    Open Activity Monitor, search for coreaudiod and kill process.
    Or open terminal and use top command to find PID and:

    sudo kill 5481

    Or whatever process number top revealed for coreaudiod.
     

Share This Page