Volume control disabled when audio interface is connected.

Discussion in 'MacBook Pro' started by watsonbl, Feb 4, 2013.

  1. watsonbl macrumors newbie

    Joined:
    Feb 4, 2013
    #1
    Macbook Pro os x 10.7.5

    When I connect my external audio interface(AKAI EIE Pro) my volume control is disabled, aka turns grey. Have tried resetting PRAM, plugging in headphones, etc but problem persists. I am using the device as an output and in sound preferences it just says "the selected device has no output controls".What is strange is this just started happening the other day, I have been using the same setup for months and never had this problem. I'm new to mac and not very technology savvy so if you instruct me to go in and reset something please be very specific, listing step by step. I have tried looking this up but I do not understand some of the suggestions such as reseting coreaudiod ( i don't know what that is or how to access it) Much appreciated.Thanks!
    - Brad
     
  2. snaky69 macrumors 603

    Joined:
    Mar 14, 2008
    #2
    That would be normal, your interface is the one managing volume as you are sending a digital signal to it, not an analogue one. Maybe you simply didn't notice before.

    There's nothing you can do about it.
     
  3. watsonbl thread starter macrumors newbie

    Joined:
    Feb 4, 2013
    #3
    I specifically remember being able to control the volume through the macs volume controls, I was doing it last week. What makes me so sure is I had to configure sound levels with the music I was playing, and I wasn't using the interface volume when trying to finely tune certain things.
     
  4. Interstella5555 macrumors 603

    Interstella5555

    Joined:
    Jun 30, 2008
    #4
    The only way to do this is if the output is set to "internal speakers." Anything else you plug in (such as HDMI) will be controlled externally.
     
  5. runebinder macrumors 6502a

    runebinder

    Joined:
    Apr 2, 2009
    Location:
    Nottingham, UK
    #5
    My rMBP and my last MBP both do this when plugged into my AV Receiver, completely normal behaviour.
     

Share This Page