Volume Control Disabled

Discussion in 'OS X Yosemite (10.10)' started by martynscott, Aug 3, 2015.

  1. martynscott macrumors newbie

    Joined:
    Mar 31, 2012
    Location:
    Derby, England
    #1
    Hi all,
    I've recently clean installed Yosemite on a new hard drive.
    Everything is fine, except every time I reboot, the volume control is disabled/greyed out on menu bar.
    I've had to use the terminal command to make it activate.
    I've tried disk permissions, repaired, reinstall. Everything.
    Can anyone suggest anything, or am I going to have to clean reinstall.

    Thanks.
     
  2. !!! macrumors 6502

    Joined:
    Aug 5, 2013
    #2
    What terminal command are you using?
     
  3. martynscott thread starter macrumors newbie

    Joined:
    Mar 31, 2012
    Location:
    Derby, England
    #3
    These two;
    sudo kill -9 `ps ax|grep 'coreaudio[a-z]' |awk '{print $1}'`
    or
    sudo killall coreaudiod
     
  4. hammie14 macrumors regular

    hammie14

    Joined:
    Mar 18, 2010
    Location:
    London, UK
    #4
    Have you tried a SMB and PRAM reset?

    I had i problem with my rMPB mid 2014 and the volume would not work at all, wiped the mac and reinstalled still failed, tried the SMB and PRAM and then it started working. I have no idea why!
     
  5. martynscott thread starter macrumors newbie

    Joined:
    Mar 31, 2012
    Location:
    Derby, England
    #5
    I did try that, but nothing, gave the headphone jack a good clean & few plug ins of headphones and it seems to have sorted it. Seems a bit weird that it only started happening after a install.
     

Share This Page