Volume Control issue

Discussion in 'Mac OS X Lion (10.7)' started by calegendre, Jul 4, 2011.

  1. calegendre macrumors newbie

    Joined:
    Jul 4, 2011
    #1
    2010 13" MacBook Pro 2.4GHz running 10.7 GM

    My volume control is greyed out and it says that no control is available for it -- yet sound plays just fine, just without the ability to control the volume.

    If I plug in a set of headphones, then unplug them, it unlocks it and I'm able to control volume for my computer's internal speakers.

    But, I don't wanna carry something around to plug and unplug just to make volume control work...

    ....just curious, is there a fix for that?

    Thanks.
     
  2. tkermit macrumors 68030

    tkermit

    Joined:
    Feb 20, 2004
  3. heppuhei macrumors newbie

    Joined:
    Mar 6, 2011
    #3
    same problem

    I have the same model and same problem.
     
  4. ajoj macrumors newbie

    Joined:
    Nov 20, 2010
    #4
    I have the same issue on my 2011 13" MBP. Booting into safe mode didn't solve the issue unfortunately...
     
  5. tkermit macrumors 68030

    tkermit

    Joined:
    Feb 20, 2004
    #5
    :( You may want to reset the Mac's PRAM as well, since among other things, that's where the speaker volume is stored. I'm sure some combination of troubleshooting steps will bring the volume control back. But it would probably be a good idea to bring this issue to Apple's attention by filing a bug report. :)
     
  6. fruitbat04 macrumors newbie

    Joined:
    Jul 8, 2008
    #6
    Exactly the same here as well.

    If you go into system preferences and check the sound, it'll say the selected device has no control outputs. Annoying.

    Must be a bug.
     
  7. calegendre thread starter macrumors newbie

    Joined:
    Jul 4, 2011
    #7
    It seems to be fixed now - I unplugged and plugged headphones in a few times and after a couple restarts after that, it seemed to still hold up. Just a little glitch I guess.

    Quite enjoying this system now..
     
  8. paulsalter macrumors 68000

    paulsalter

    Joined:
    Aug 10, 2008
    Location:
    UK
    #8
    Either Lion or could be this

    http://forums.macrumors.com/showthread.php?t=239287

    seen this mentioned quite a few times
     
  9. iJudge., Jul 21, 2011
    Last edited: Jul 21, 2011

    iJudge. macrumors newbie

    Joined:
    Jul 21, 2011
    #9
    I have been getting this same problem (3 times now).

    I don't think it's the sensor or I/O board issue described on the Apple Support site because it is a bit different for a couple of reasons:

    1. The red light in the audio output doesn't turn on - as it does with the other issue.
    2. In sound preferences it shows "No selected devices" whereas the other issue says something else i.e. "Digital Output".
    3. If I restart, my sound control abilities return :) .

    EDIT: Then again, when I plug my iPhone headphones in and out, it works as well.

    Fingers crossed its a Lion glitch and not a hardware issue that requires the board to be replaced.

    Another user found this worked:

    "Something else to try, because this same thing happened to me a few years back on a brand new Mac Book. The problem was caused by me shutting down the computer with the headphones in the jack. Once the computer was off, I had unplugged the headphones. The next time I started up the computer, the red light was on and I had no audio. I had tried inserting the plug several times in hopes of triggering the little switch, but that seemed random and prone to causing more frustration. I decided to work backwards and think of things that might have caused it. Finally stumbled onto this one...while the computer was on, I inserted the headphone jack. I then shut the computer down with the headphones plugged in. Still keeping the headphones plugged in, I powered the computer back on. Once I got to the login screen (just a good spot to know that all of your hardware has probably been initialized), I was able to unplug the headphones and have audio restored. I should also mention that I was able to reproduce the problem and fix it with the same solution several times.

    Granted, this would not explain the switch getting stuck due to dirt or grime or it getting bent or jammed due to improper use. That stuff can happen. However, before you go jamming a toothpick (or even a q-tip) into your headphone jack...or simply inserting the jack over and over in hopes that it will magically start working again...give this a shot. It'll take you very little time to try, and if it doesn't work...it's one more thing you can cross off the list before resorting to one of the other methods."
     
  10. trfjason macrumors member

    Joined:
    May 28, 2010
    #10
    I have the exact same problem. Tried to reset NVRAM and PRAM, it doesn't solve the problem.

    The only temporary solution is to reset the computer.
     
  11. Drail14me macrumors newbie

    Joined:
    Jul 23, 2011
    #11
    Same problem here right after Lion upgrade...

    I'm having the same issue. All controls that control the volume of the internal speakers will not function. If I plug in a set of headphones, the volume controls work. As long as the headphones are plugged in, all volume controls work fine and continue to work after unplugging. However, after a restart, the volume controls are greyed out and the volume is set at the same level as it was when the Mac was shut down if the headphones are not plugged in.

    I think I've correctly submitted a bug ticket. Hopefully we'll see a patch for Lion soon.
     

Share This Page