Volume icon is greyed out (locked)

Discussion in 'MacBook Air' started by Viantef, Apr 26, 2014.

Thread Status:
Not open for further replies.
  1. Viantef macrumors member

    Joined:
    Jun 20, 2013
    #1
    I used the reset pram but nothing happened. (ctrl + opt + p + r), although when I did this, it reinstalled OSX. So, I'm assuming thats pram reset.

    I goto preferences>sound> and it's just blank. No mention of digital audio or internal speakers, just blank. However the mute box is checked and its greyed out.

    There's no red led in the headphone jack because this is the macbook air.
    I also accidentally reinstalled the OS, and still no cigar.
    Anything else I can do before taking it to an Apple store?
     
  2. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #2
    PRAM reset does not reinstall OS X. It's just a form of hardware reset.
    PRAM reset is actually (command+option+p+r) (NOT ctrl+opt+p+r) The only difference is Command, not Control.
    Restart your MBAir, holding those 4 keys. You should hear the boot chime sound. Continue holding the same 4 keys, until you hear the chime 2 more times, then release the keys to let your Air restart normally. This would take, at the most, a minute.
     
  3. Viantef thread starter macrumors member

    Joined:
    Jun 20, 2013
    #3
    damn you Man it's now reinstalling OS X again!!!! Another 4 hours :'-(
     
  4. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #4
    Why would you _choose_ to reinstall OS X?
    The PRAM reset does NOT start the reinstall, nor would it force you to reinstall if you don't want to do that. It only resets your Mac, and will continue to do that while you continue to hold all 4 keys. Other than some screen flashing, which may or may not be visible - no menus, and no other text will appear. If you see any text, then you continue to use the wrong keys. Just as a reminder: Command + Option + p + r
    Those keys, all of them, no others, Restart, then hold those 4 keys until you hear the second chime. If you don't hear anything, just keep holding the keys for about 2 minutes, just to allow your Mac time to respond - then release those 4 keys to allow your Mac to boot normally. If any text comes up on the screen while you are holding the keys - you are not doing this correctly. Press and hold the power button to force your Mac power off. Try the PRAM reset once more. If you STILL get to the recovery partition (the list of various choices, including reinstalling OS X), then something else is wrong, and you need to force it OFF again. Take your Mac to someone who knows how to help you.
     
  5. Dweez macrumors 65816

    Dweez

    Joined:
    Jun 13, 2011
    Location:
    Down by the river
    #5
    Quoted for truth. Did you figure out the audio issue?
     
  6. Viantef thread starter macrumors member

    Joined:
    Jun 20, 2013
    #6
    The thing is, there is no chime at all. Sound is gone. Every time I do this, the screen just continues to flash on and off about every 3 - 5 seconds. Then when I release the keys, it will boot into the OS. So theoretically, its going to continue to flash if I kept my hand on 4 of those keys.

    I actually got it to work last night by turning off the bluetooth then restarting the computer but it failed again this morning.

    1. So, force shut mac

    2. Turn Mac on

    3. Immediately press cmd + opt + p + r? (Remember, I have no boot chime)
     
  7. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #7
    Yes, that's your PRAM reset - the flash every few seconds is each reset. So, that's working, but there's no good result for your sound.
    Boot to your diagnostic test (Restart, holding the D key) - and run both the standard and extended tests.
    If you have an internet connection (and your MBAir is a 2013 model or newer), then the diagnostics test may suggest other resources.
     
  8. Viantef thread starter macrumors member

    Joined:
    Jun 20, 2013
    #8
    I ran the diagnostics test, and it said something was wrong with the Audio. I just said "forget it", and called Apple Tech Support and we were on the phone for about 10 minutes trying to reset the pram/smc, still no cigar. So he set up an appointment for me at the Apple Genius bar tomorrow.

    So what do you think, I'll be walking away home with my Macbook tomorrow or letting my baby go for a few days? :(

    Thanks for the help man I really appreciate it.
     
  9. Ravenis macrumors member

    Joined:
    Feb 4, 2014
    #9
    Depending on what the AHT said likely there is a hardware issue. If you wanted to run it again, write down the reference code and check it here:

    http://support.apple.com/kb/TS4575


    It will most likely be shipped off to depot for repair. Setting up with ARS was going to be the next step from AppleCare either way.
     
  10. bizzle macrumors 6502a

    Joined:
    Jun 29, 2008
    #10
    Probably loose I/O flex cable. Pretty common on all MacBook Airs 2010 and newer.
     
  11. brilliantthings macrumors 6502

    Joined:
    Feb 13, 2011
    #11
    Had to get the logic board replaced when this happened to MBA 2010.
     
  12. Viantef thread starter macrumors member

    Joined:
    Jun 20, 2013
    #12
    Yea, I went to the Apple Store yesterday. They're going to replace the logic board. It looks like this is also affecting my performance in iMovie and Final Cut Pro. I can't do anything in the programs without getting the beach ball. :mad:
     
  13. Vishal Singh macrumors newbie

    Joined:
    Sep 13, 2014
    #13
    One and final solution for greyed out Volume in Mac Book

    Hi All,

    I spent almost 3 days in trying to solve Mac Book Air - Greyed out (Max volume) icon issue. I was not able to play any sort of sound at all and i tried following things :

    1) Resetting the System Management Controller (SMC) : http://support.apple.com/kb/ht3964

    2) Resetting PRAM :
    http://support.apple.com/kb/PH14222

    3) OS X Mavericks: Reinstall OS X
    http://support.apple.com/kb/ph13871

    4) After following all these steps mentioned above I raised a ticket to Apple support : Ticket id 661159575. Spent another 3-4 hours and followed the same steps in line..once again. The support team if re-install OS did not work then it is surely H/W problem and I should go to Apple store...But I was not positive of the H/W issue as it was not sinking in..

    Then as I am from S/W background I knew that permissions and lock issues makes life in Linux/Unix based kernels as like MacBook Air OS - Maverics or OS X Lion. Then I did two things and restarted my Mac and when I heard the sound..I literally wanted to kiss myself and treat myself...

    So the solution which will surely work is :
    1) Browse to the folder \Library\Audio and then right click on the Audio folder and click "Get info" then down below you will see a small "lock" icon click on it and it will open..then you have to add your macbook account in to the permissions space and make sure you give "read & write both" and again click
    on the lock icon so that it is locked again and no one else can change the permissions. close the "Get info" window and follow next step as mentioned :
    2) Now you have to run one command which will release any lock on "audio" folder..
    open the terminal and run : cd \Library\audio chmod -R 777
    Restart your mac and get ready to rock

    This will definitely save lots of money guys..Apple should definitely make a KB from this post :)

    Cheers
     
Thread Status:
Not open for further replies.

Share This Page