Volume Problem - Prohibitory Sign

Discussion in 'MacBook' started by mgmusicman94, Jun 13, 2011.

  1. mgmusicman94 macrumors 6502a

    Joined:
    Nov 16, 2008
    #1
    I'm having a problem with my volume on my MacBook C2D. The volume keys (F10,F11,F12) work when headphones or speakers are plugged in. When I unplug them, though, I get no sound out of my computer's speakers and when i try to adjust the volume I see this:

    [​IMG]

    Any help would be greatly appreciated!
     
  2. ratzzo macrumors 6502a

    ratzzo

    Joined:
    Apr 20, 2011
    Location:
    Madrid
    #2
    Try tinkering in the Sound palette of Sys Prefs, sometimes my Mac doesn't automatically detect neither headsets nor speakers, though they've been connected a thousand times before.
     
  3. mgmusicman94 thread starter macrumors 6502a

    Joined:
    Nov 16, 2008
    #3
    It works fine with headphones and speakers, but not with the built in speakers.
     
  4. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #4
    Is there a red light visible inside the audio out port? If so, plug and plug the 3.5mm audio connector repeatedly until it goes away.
     
  5. mgmusicman94 thread starter macrumors 6502a

    Joined:
    Nov 16, 2008
    #5
    Wow, surprisingly that worked... Care to explain why/how that fixes the problem or what the problem was in the first place?
     
  6. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #6
    Telepathy.
    Or better, it is a common problem, as unplugging a 3.5mm connector from the audio out port sometimes triggers the optical audio out side of the port, thus it is stuck in its optical mode. To get it unstuck, repeatedly unplugging and plugging the 3.5mm connector will work, often.
     
  7. mgmusicman94 thread starter macrumors 6502a

    Joined:
    Nov 16, 2008
    #7
    Makes sense! Thanks!
     

Share This Page