Volume within apps affecting ringer volume - problem.

NotMyName

macrumors member
Original poster
Nov 21, 2016
46
2
iPhone 6S
iOS 12.1.4 (recently switched to this).

I can't say for 100% although i'm fairly sure this has only happened since the move to 12.1.4 from 12.1.3 so the first question i guess is can i somehow 'downgrade' to 12.1.3?

Basically the problem is that even recently i was able to open an app (Snapchat for example or various games) and have a volume for those apps. Something reasonably loud. I would also have my ringer volume which would be significantly different - only 3 notches. <----- this is actually not the problem.
The problem is that now if i increase the volume within snapchat or a game then it also changes my ringer volume. If i change the ringer volume then it makes it quiet within other apps. I didn't notice this until i'd been playing a game and had the volume up pretty much full and then later that day i go to bed only to be woken by an alarm instead of being on 3 notches and is just quiet enough to wake me up was on full notches waking up not only me but also my partner and clearly the neighbours in the connecting room too.

I want to change it back to how it was but since i don't even know how it ended up being as it (currently) is, i don't know how to do that.
 

mattguy10

macrumors 6502a
Aug 18, 2010
588
279
iPhone 6S
iOS 12.1.4 (recently switched to this).

I can't say for 100% although i'm fairly sure this has only happened since the move to 12.1.4 from 12.1.3 so the first question i guess is can i somehow 'downgrade' to 12.1.3?

Basically the problem is that even recently i was able to open an app (Snapchat for example or various games) and have a volume for those apps. Something reasonably loud. I would also have my ringer volume which would be significantly different - only 3 notches. <----- this is actually not the problem.
The problem is that now if i increase the volume within snapchat or a game then it also changes my ringer volume. If i change the ringer volume then it makes it quiet within other apps. I didn't notice this until i'd been playing a game and had the volume up pretty much full and then later that day i go to bed only to be woken by an alarm instead of being on 3 notches and is just quiet enough to wake me up was on full notches waking up not only me but also my partner and clearly the neighbours in the connecting room too.

I want to change it back to how it was but since i don't even know how it ended up being as it (currently) is, i don't know how to do that.
I believe Apple has stopped signing 12.1.3, so downgrading to that is no longer possible.

From what you’re describing, it sounds like you have “Change with Buttons” enabled in:

Settings > Sounds & Haptics

You’ll want to disable this setting so that when you use the volume buttons only the overall system volume is adjusted without adjusting the volume of the ringer and alerts.

If that doesn’t help, try a hard reset by holding down the power & home buttons simultaneously until the screen turns off and the  logo appears.

If that doesn’t help, you can try a “Reset All Settings” in:

Settings > Reset

You’ll have to obviously adjust all of your settings back to the way you had them and re-enter any saved WiFi passwords, but it may fix the problem you’re having if it’s just some random glitch.
 

NotMyName

macrumors member
Original poster
Nov 21, 2016
46
2
I believe Apple has stopped signing 12.1.3, so downgrading to that is no longer possible.

From what you’re describing, it sounds like you have “Change with Buttons” enabled in:

Settings > Sounds & Haptics

You’ll want to disable this setting so that when you use the volume buttons only the overall system volume is adjusted without adjusting the volume of the ringer and alerts.

If that doesn’t help, try a hard reset by holding down the power & home buttons simultaneously until the screen turns off and the  logo appears.

If that doesn’t help, you can try a “Reset All Settings” in:

Settings > Reset

You’ll have to obviously adjust all of your settings back to the way you had them and re-enter any saved WiFi passwords, but it may fix the problem you’re having if it’s just some random glitch.
Thanks for the reply. I went where you said and this is what the setting was (I haven't changed it):

 

mattguy10

macrumors 6502a
Aug 18, 2010
588
279
Thanks for the reply. I went where you said and this is what the setting was (I haven't changed it):

I’d give my other options a try, especially the hard reset as you won’t lose any settings doing that. Other than that, I’m not sure what could be causing that...