VPN client on Yosemite

Discussion in 'OS X Yosemite (10.10)' started by yufretti, Aug 5, 2014.

  1. yufretti macrumors newbie

    Joined:
    Aug 5, 2014
    #1
    Hi there!
    I have a problem with my VPN on Yosemite.
    In my home, i have a mac mini server, with a VPN PPTP server (I use Server App from Apple). From my workplace, i try to connect with my home VPN, Yosemite try to connect, but after a few seconds will return an error. From Yosemite console log, i can see this error:

    pppd 2.4.2 (Apple version 786) started by Yuri, uid 501
    pppd[5758]: pptp_get_router_address
    pppd[5758]: PPTP connecting to server (servername, serverip)...
    pppd[5758]: PPTP connection established.
    pppd[5758]: Connect: ppp0 <--> socket[34:17]
    pppd[5758]: LCP: timeout sending Config-Requests
    pppd[5758]: Connection terminated.
    pppd[5758]: PPTP disconnecting...
    pppd[5758]: PPTP disconnected

    Someone has the same problem or know how to fix???
    If I try to connect to the same VPN server with iPhone or Windows client i don't have any problem.
    Also, before upgrade to Yosemite (Mavericks) everything worked correctly!
    Thank you all!

    yufretti
     
  2. schreiberstein macrumors newbie

    Joined:
    Oct 12, 2013
    #2
    I experienced the same issue on Yosemite PB 2 while trying to connect to my L2TP-IPSec provider. No, I don't have a solution for this, either. I reported it.
    Hopefully, it'll be fixed in the next beta.

    Best regards
    schreiberstein
     
  3. Fzang macrumors 65816

    Fzang

    Joined:
    Jun 15, 2013
    #3
    Are you using the built-in VPN functionality? I found that it didn't work, but an external app to handle your VPN connection (I'm using VyprVPN's app) works perfectly fine in Yosemite.
     
  4. schreiberstein macrumors newbie

    Joined:
    Oct 12, 2013
    #4
    As far as I'm concerned, I'm using the OS X native VPN-function.
    The external configuration app of my provider (PureVPN Client) just re-uses the OS X native functions, hence it doesn't make a difference.
    Tunnelblick (OpenVPN client) works, I guess.

    Best regards
    schreiberstein :apple:
     
  5. myname70 macrumors 6502a

    Joined:
    May 5, 2014
    #5
    Hi. How can I enable the built in VPN server on Yosemite ?
     
  6. madman555 macrumors member

    Joined:
    Feb 20, 2009
    #6
    Does anyone have an update? I'm having the same problem using PPTP trying to connect to my office
     
  7. pmau macrumors 65816

    Joined:
    Nov 9, 2010
    #7
    Bump. Same issue. Tried various PPP options on my server. No solution.
     
  8. edorizzi macrumors newbie

    Joined:
    Oct 18, 2014
    #8
    Yosemite PPTP issues

    I experienced PPTP issues from the very first pre-release and now on the official Yosemite release.

    I found a workaround :

    PPTP does not work if I have my ethernet card IPv4 manually configured, BUT if I use an Automatic (DHCP) configuration VPN (PPTP) does work.

    Although I set manually everything as in DHCP, VPN does not work.

    Don't ask me why, but this is working for me, from Yosemite pre-release 1.0 up to Yosemite official.

    Hope this could help
     
  9. topsterhimself macrumors newbie

    Joined:
    Oct 18, 2014
    #9
    That did the trick, thanks a lot. With dhcp i am able to connect to windows-pptp-servers again.

    Same goes for wireless connection, if its configured through dhcp it works, with a static ip it doesn't.
     
  10. pmau macrumors 65816

    Joined:
    Nov 9, 2010
    #10
    Wow. A big Thank You from me, too.

    At first I was confused when you mentioned DHCP and VPN, but then I reconfigured my Ethernet to DHCP and suddenly it made sense.

    It's not what I wanted, since I cannot pin my IP at DHCP level, but at least it works.

    (I have no control over our DHCP server, unfortunately.)
     
  11. Lorylua macrumors newbie

    Joined:
    Oct 28, 2014
    #11
    Yosemite update and shrew not working

    Hi there, since I updated to Yosemite I can connect to VPN it says "bringing up tunnel" and then quit unexpectedly.
    I am using automatic DHCP so Im not sure what to do do... Anyone can help?
     

Share This Page