VPN connection using Mac OS X's built-in Network Preferences?

Discussion in 'Mac Apps and Mac App Store' started by Bengt77, Nov 11, 2008.

  1. Bengt77 macrumors 68000

    Bengt77

    Joined:
    Jun 7, 2002
    Location:
    Europe
    #1
    Hi all,

    For school, I need to set up a VPN connection to be able to connect my MacBook to the internet. While my school offers the Cisco VPN Client with a preconfigured PCF settings file, I would much rather use Mac OS X's built-in VPN capabilities, through the Network Preferences.

    Now, my problem is that I don't really know what to do to get this working. Using an online password decoder, I already found out what the password for my school's VPN connection is. But how do all the settings translate between the Cisco VPN Client and Mac OS X's VPN configuration screen?

    The PCF file tells the Cisco VPN Client to use Group Authentication, with a group name and a group password (the one I already decrypted). These are already filled in. When starting a connection, I am then asked to fill in my student login details. Now, in the VPN settings screen in System Preferences, there is a box for Account Name. Am I right in thinking this is the box where I fill in my student ID? Or does the group name go here? Then, when I click Authentication Settings..., I can fill in a password. I assume this is where my student password goes? Or should I fill in the password I decrypted?

    Neither seems to work. But that may be because of the next step: Machine Authentication. There, I can choose between a Shared Secret and a certificate. I can not choose nothing. As I don't have a certificate, I'm guessing I should be able to find what to use as a Shared Secret in the Cisco VPN Client's PCF file. Am I right? I can not leave the field blank, as I constantly get an eror message saying "The IPSec Shared Secret is missing. Please verify your settings and try again."

    What do I have to do to get it working? I have a server address, a group name (though the VPN screen in System Preferences says it's only optional), a decrypted group password and finally my personal student login name and password. What goes where? Anyone?!...

    Here are the contents of the PCF file:
    Code:
    [main]
    Description=VPN Hogeschool Leiden
    Host=vpn.hsleiden.nl
    AuthType=1
    GroupName=VPN-HL
    GroupPwd=
    enc_GroupPwd=E7F172645F7D587DC6E6A8A969B010BB385D2311E90B20F1E0DA24D817F9FA10514F08E0A439C40C68582C225529332034674D0AB04FDA1E
    EnableISPConnect=0
    ISPConnectType=0
    ISPConnect=
    ISPCommand=
    Username=
    SaveUserPassword=0
    UserPassword=
    enc_UserPassword=
    NTDomain=
    EnableBackup=0
    BackupServer=
    EnableMSLogon=1
    MSLogonType=0
    EnableNat=0
    TunnelingMode=0
    TcpTunnelingPort=10000
    CertStore=0
    CertName=
    CertPath=
    CertSubjectName=
    CertSerialHash=00000000000000000000000000000000
    SendCertChain=0
    PeerTimeout=90
    EnableLocalLAN=0
    ISPPhonebook=
    USElegacyikeport=1
     
  2. yippy macrumors 68020

    yippy

    Joined:
    Mar 14, 2004
    Location:
    Chicago, IL
    #2
    I am not sure the mapping, but keep in mind it might not be possible. Cisco's VPN has some proprietary connection options that ONLY work with the Cisco client.
     
  3. francisquinha macrumors newbie

    Joined:
    Sep 21, 2009
    #3
    The Solution

    Hello!

    Check out this page and follow the instructions.
    I had the same problem as you and just found this solution. Now the built-in client is working fine.

    Hope this helps!
     
  4. edesignuk Moderator emeritus

    edesignuk

    Joined:
    Mar 25, 2002
    Location:
    London, England
    #4
    I don't think your school will appreciate you posting your VPN host and shared group password.
     
  5. mgamiet macrumors newbie

    Joined:
    Oct 7, 2011
    #5
    Resolved: "The IPSec Shared Secret is missing"

    I just resolved this issue.

    I manage the VPN at work and was trying to connect via ipad then I got the message
    "The IPSec Shared Secret is missing. Please verify your settings and try again."

    If your environment is a Microsoft VPN (Routing and Remote Access)

    The solution is:
    1. Delete existing VPN that didn't work.
    2. Create new VPN and do NOT add anything on the L2TP tab.
    3. Click on the PPTP Tab and enter the information here - your need description, server, account - I leave passwrod to Ask Every time.
    4. All other settings - leave the defaults.

    This worked for me.
     

Share This Page