VPN connects, but no internet access?

Discussion in 'macOS' started by aqua.mac, Jun 29, 2016.

  1. aqua.mac macrumors newbie

    Joined:
    Jun 29, 2016
    #1
    We have a Mac running OS X 10.11.5 that can not connect to the internet when it's connected to the VPN (PPTP). Once it's connected, it can only connect to things on the local network that the VPN has joined to.

    For example when connected to VPN, the Mac can access things like our internal file sharing and Intranet sites, but can not go onto internet connected sites in Safari.

    We have checked "Send all traffic over VPN connection" in the VPN connection settings. In terminal we can ping "google.com" and "8.8.8.8" when connected to the VPN. No other Internet enables apps work either (e.g. Dropbox, OneDrive, Skype etc.)


    Any ideas?
     
  2. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #2
    Assuming that your local and remote networks use different subnets (e.g. both are not 192.168.1.x), uncheck "send all traffic over VPN connection" and in the Network prefs, set the VPN to be the second network from the top. The top one should be whatever you use to connect to the internet.
     
  3. aqua.mac thread starter macrumors newbie

    Joined:
    Jun 29, 2016
    #3
    Thanks for the response JohnDS,

    We have tried your recommendation but unfortunately this hasn't worked. Local and remote networks are on different subnets.

    Is there anything else we can try?
     
  4. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #4
    Can you post two screen shots of our Network prefs main page one with the VPN highlighted in the left pane and one with the regular wifi or ethernet highlighted. (Do this with the VPN connected.)
     
  5. simon lefisch macrumors 6502a

    simon lefisch

    Joined:
    Sep 29, 2014
    #5
    What type of VPN server are you connecting to (Windows)? I have MBP that is able to connect to my Server 2008 R2 using L2TP w/o probs. Maybe it's a setting in the server itself?
     

Share This Page