VPN issue in iOS 8.2

Discussion in 'iOS 8' started by JohnWick, Mar 18, 2015.

  1. JohnWick macrumors member

    Joined:
    Mar 10, 2015
    #1
    Hi,

    I`m using iPhone 6, iOS 8.2

    My problem is that I cannot use VPN on my cell. When I connect to a VPN (like hot spot shield) it says it is connected, but when I open a webpage, a loading icon comes beside my VPN icon on top of screen, and then it opens NOTHING until I disconnect my vpn.

    I have tried many applications for using this; free and premium! No luck!

    Can anyone help me please?

    Thanks,
     
  2. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #2
    Does this occur everywhere on every network or just in particular places?
     
  3. scaredpoet macrumors 604

    scaredpoet

    Joined:
    Apr 6, 2007
    #3
    I'm able to connect over VPN fine on my iPhone 6 Plus, using OpenVPN as well as Junos Pulse.

    I'm not sure if Hotspot shield is using their own custom app, but if they are and it hasn't been updated in a while, that might be your problem. iPhones starting with the 5S use 64-bit processors and at least for Junos and OpenVPN, that caused problems when their apps were still compiled for 32-bit devices only.

    The only other possibility would be that the network you're on has started blocking ports used by Hotspot Shield.
     
  4. JohnWick thread starter macrumors member

    Joined:
    Mar 10, 2015
    #4
    the problem is not the VPN, it's the whole matter of using VPNs.

    by the way, to let you know what I did in installation, I installed thr application, created an account, confirmed my mail, created the profile in phone, tried to tunnel to europe countries. it did connect to those countries, but when I tried to open a webpage in my Safari or Chrome, it did not open anything, then disconnected me from VPN and WiFi. So, nothing!

    then I tried using VPN via Celluar Data, it connected to VPN but did not open anypage; just like the way I did via WiFi. It disconnected and did not open anything.
     
  5. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #5
    Are you sure that you set it up correctly? Have you checked the Send All Traffic option as well?
     
  6. JohnWick thread starter macrumors member

    Joined:
    Mar 10, 2015
    #6
    I dont think either of them is the problem, since I easily connect to the same VPN on the same network using other devices

    Also my colleague uses 5S and the same app and he easily connects to the network...

    This is getting weird... Any other idea?...

    BY the way, my brother bought a new iPhone 6 last night, and again that suffers from the same issue...
     

Share This Page