VPN not working after upgrade

Discussion in 'OS X Yosemite (10.10)' started by madman555, Oct 17, 2014.

  1. madman555, Oct 17, 2014
    Last edited: Oct 17, 2014

    madman555 macrumors member

    Joined:
    Feb 20, 2009
    #1
    I updated to Yosemite last night and now my VPN connection to my office isn't working. It tries a couple of times and then I get this:

    Fri Oct 17 14:50:57 2014 : LCP: timeout sending Config-Requests

    This occurs when I'm using the wired ethernet. I've been using the wired ethernet for years without any problems. Until last night.

    The weird thing is if I disable the wired ethernet and enable wifi, I'm able to connect to the VPN on the same computer.

    I'm using PPTP.

    Any help would be greatly appreciated. I've done a lot of googling and have yet found anything helpful

    Edit:
    I did some more testing and noticed that on the wifi, it logs:
    pptp_get_router_address
    pptp_get_router_address 192.168.20.1
    PPTP connecting to server '[REMOVED ADDRESS]' ([REMOVED IP])...

    but when trying with the ethernet, it logs:
    pptp_get_router_address
    PPTP connecting to server '[REMOVED ADDRESS]' ([REMOVED IP])...

    192.168.20.1 is my router's IP. I'm using an Airport Extreme
     
  2. madman555 thread starter macrumors member

    Joined:
    Feb 20, 2009
    #2
    So I got it to work. For as long as I've used this Mac, I've had the ethernet set to manual. I defined the IP address, subnet, and router IP, which has always worked.

    Just to test, I tried DHCP and tried and it worked! Then I tried DHCP with manual address (using the same IP I had when I had it set to manual) and it worked!

    I went through all the settings and they look identical to me under Manual and DHCP with manual address.

    So I'm not really sure what the difference is.
     

Share This Page