iPhone VPN not working in iOS9 beta

Discussion in 'iOS 9' started by locust76, Aug 31, 2015.

  1. locust76 macrumors 6502a

    Joined:
    Jan 23, 2009
    #1
    Hello,

    I installed the iOS9 public beta (the very first one that was public) on my phone, and immediately noticed that the VPN connection to my home firewall stopped working properly. It connects and negotiates the phases just fine, and traffic gets sent from my phone through my firewall to the intended destination, but when it comes back, it leaves my firewall into the VPN tunnel to my phone, but the phone doesn't seem to accept the incoming packets. Even after updating to the latest iOS9 public beta and resetting my network settings, the thing still doesn't want to receive VPN data.

    The exact same VPN connection works just fine on my iPad running 8.4, so it's definitely an issue with iOS 9.

    Is there some kind of known issue with VPNs, or is this an isolated case? I've tried my VPN to my home, and also an L2TP VPN to my VPN provider, both don't work anymore.

    The only thing I haven't tried is a complete reset of the phone, but I'd rather wait until the final version of iOS 9 comes out before going down that road.
     
  2. Didier macrumors newbie

    Joined:
    Jul 24, 2012
    #2
    No issues with VPN connections here, works perfect in iOS 9
     
  3. RandomKamikaze macrumors 6502a

    RandomKamikaze

    Joined:
    Jan 8, 2009
    Location:
    UK
    #3
    L2TP VPN works fine on my device running latest PB
     
  4. lemimouth macrumors regular

    Joined:
    Feb 14, 2015
    #4
    No problem here. Have you tried to recreate your vpn connection ? I don't know if vpn configuration is kept after resetting network settings
     
  5. locust76 thread starter macrumors 6502a

    Joined:
    Jan 23, 2009
    #5
    Here's an update:
    Last night I completely reset my phone after making a backup. Without restoring the backup, I took my freshly booted phone and recreated the VPN connection. It still didn't work. Oddly enough, when I connect to my VPN connection from within my WiFi network, it works just fine.

    I think this has something to do with NAT Traversal. With IPSec, the standard port used is 500, but if NAT is detected, it will switch to 4500. NAT would be detected if, for example, the IPSec gateway was not directly connected to the internet.

    My home network has NAT traversal. iOS 8 deals with this just fine, but iOS 9 can't handle it for some reason.

    I have NAT traversal, because I'm forced to use a box from my ISP (it's a pretty good home box but not nearly as nice as my Fortigate Firewall), so I have my Firewall sitting in between my network and the network provided by my ISP, acting as a DMZ and forwarding ports to my machines inside my network.

    I think that iOS 9 can connect, but the actual payload is being lost because somehow the phone forgets about NAT Traversal and thinks these packets on port 4500 are unsolicited and therefore drops them. That's the only explanation I can come up with.

    Is there a second-level support system at Apple I can contact? I don't want to do that stupid "set up a time for a phone call with some jerkoff who think's he's an IT specialist because he can reinstall an OS" crap. I'm gonna need to talk with someone at Apple who knows networking.
     
  6. apapas macrumors newbie

    Joined:
    Sep 15, 2015
    #6
  7. locust76 thread starter macrumors 6502a

    Joined:
    Jan 23, 2009
    #7
    Yeah that's my thread ;) unfortunately deleting the VPN configurations and rebooting didn't help at all...

    What does your VPN setup look like? Does your VPN gateway have a direct connection to the internet, or is it behind a NAT device?
     

Share This Page