VPN PPTP disconnects from Windows network on tiger and leopard

Discussion in 'macOS' started by rpeters83, Jan 15, 2008.

  1. rpeters83 macrumors regular

    Joined:
    Oct 31, 2007
    #1
    I'm connecting to a VPN network and while I can connect just fine and connect to a remote desktop (using latest RDP) and a "local" IP, it will disconnect me after a few minutes. This happens on both my Tiger (wired) and Leopard (802.11n/5ghz) machines. Similarly, I loose connection if I SSH to one of the linux boxes on the server.

    However, when I connect to the same VPN network using a windows machine, it stays up perfectly. I thought at first it was just Leopard, but my Tiger machine did it too. The connection is fine on my end.

    Any ideas? This is for work so any help is appreciated. Thanks!
     
  2. chinadoll macrumors newbie

    Joined:
    Feb 27, 2008
    #2
    i have the same issue

    I have the exact same problem. I have a Macbook, but all of my co-workers have PCs, which have no problem connecting and staying connected to the VPN PPTP. But after exactly 2 minutes, the connection will drop, unless I am connected to another computer via Skype. (However, this requires me to call the testing service on Skype every 50 seconds.)

    If you find a solution to this I'd be very glad to hear it!
     
  3. questorz macrumors newbie

    Joined:
    Mar 16, 2008
    #3
    Mine too...

    My Leopard does the exact same thing... drives me crazy...
     
  4. rpeters83 thread starter macrumors regular

    Joined:
    Oct 31, 2007
    #4
    This was fixed for me in 10.5.2.
     
  5. chinadoll macrumors newbie

    Joined:
    Feb 27, 2008
    #5
    fixed in 10.5.2?

    I upgraded to Leopard when my friends bought it for me, but it hasn't changed the problem. Do you have any idea what you might have done? I'm learning to just live with it and use other people's computers, but it's still a huge hassle sometimes.
     
  6. questorz macrumors newbie

    Joined:
    Mar 16, 2008
    #6
    VPN Disconnect Problem with PPTP connects...

    I have 10.5.2 and it still does it. Can fire up a Windows XP machine beside my mac on the same network and it's rock solid on the VPN connection... maybe 10.5.3... not holding my breath... I noticed there are some alternative 3rd party VPN software programs for Mac... just wonder if anyone has good success with them?
     
  7. abhatop macrumors newbie

    Joined:
    Apr 10, 2008
    #7
    same thin for me. new MBP and pptp vpn sucks. i figured out that the problem does not exist in every environment. let me explain:
    i want to connect with pptp to customer A and customer B:
    conntect to both from my company lan - customer A (ISA Server 2006) works fine, no disconnect. customer B (Cisco Pix) after 2.5 minutes the disconnect occours. i have tried this with two different gateways in my company with exactly the same effect (first with isa server too and second with pix).
    the funny thing is when it try the same stuff from my home network (linksys and dlink routers) BOTH connections (customer a and b) working well with no disconnect.

    would be great if anybody has a solution for this, beause this realy sucks.
     
  8. abhatop macrumors newbie

    Joined:
    Apr 10, 2008
    #8
    Hi,

    OK - after a lot of research i can say following: if pptp works on the mac depents of the firewall settings on your location (you gateway). If you use a cisco pix (or asa) you can add the pptp-vpn fixup command. It seems MS-ISA Server has problem with the mac os x pptp client - i work on this and if i find a solution i will post it. Maybe somebody else has an idea for further assistance on this problem.
     
  9. questorz macrumors newbie

    Joined:
    Mar 16, 2008
    #9
    UPDATE: PPTP VPN woes FIXED for me in 10.5.4

    10.5.4 appears to have fixed my VPN connection woes to our Windows 2003 VPN PPTP work server. Basically I could connect, fire up remote desktop, and connect to an internal work server. It would work for about 5 minutes and then the connection would stop responding. Disconnecting/reconnecting to the VPN works OK for a another few minutes and then the same. It seemed it would freeze worse when I just let the connection set without any activity. (As I have said previously in the thread it worked 100% from another laptop with windows XP on the same network, etc). Since 10.5.4 I have been logged in without any problems and no frozen responses. I have let the VPN connection set idle with remote desktop connected to a server for a lengthy period without problems. It drove me nuts, glad they finally fixed it! :D
     
  10. MiBi4ever macrumors newbie

    Joined:
    Dec 25, 2008
    #10
    i have the same ****ing problem

    does upgrading to 10.5.4 really fix this prob men ?

    this drove me crazy . omfg
     
  11. questorz macrumors newbie

    Joined:
    Mar 16, 2008
    #11
    VPN PPTP & Leopard

    I currently have 10.5.6 and it still hasn't corrected it 100%. No drops but it freezes when I'm connected via VPN and for example RDP'd into a machine. It will usually freeze if I'm looking at another screen or walk away for a few moments. It seems the freezing usually starts when there is very low activity. It usually will unfreeze after a few moments of waiting. On the same Macbook I can open up VMware Fusion and launch a WinXP session and stay connected all day without any freeze ups.
     
  12. ming.teo macrumors newbie

    Joined:
    Apr 29, 2009
    Location:
    Perth, Western Australia
    #12
    This issue isn't fixed

    I have my router and modem set up to forward PPTP VPN port 1723.

    On OS X Leopard 10.5.6 with the in-built VPN connector, it can connect and authenticate, but as soon as I try to access anything at all, PPTP hangs up.

    With the same machine, taken to work, connecting to the work wireless network, and using the same VPN settings, it works just fine, no hang up. This makes it sound like it's a problem with my home router/modem setup.

    However, with that same setup, if I boot the same machine into Windows XP SP3 in Boot Camp, and connect to the VPN using the in-built VPN connector, I can connect, authenticate, and hold the connection just fine. This makes it sound like it's not a problem with my home router/modem setup, but a problem with OS X. Something that, in my mind, had been disproven earlier!

    I've read during my months of Google trawls to find a solution to this issue, that it may:

    1. Be a problem with VMware Fusion's Virtual Network Adapters (I have Parallels' Virtual Network Adapters, which I am yet to test turning them off)
    2. Be a problem with the version of pppd Leopard uses (2.4.2, apple version 314.) Apparently it's the latest version of pppd and does not interact so well with some older VPN servers (bad legacy support?)

    I've found linux tutorials on manually configuring pppd which apparently works for linux people, but it seems unable to find the pptp library it needs when I try to apply the fix & connecting through pppd in Terminal.

    I've even tried using third-party VPN connectors like DigiTunnel, but no luck (though someone else's setup + VPN server type/setup may work with this.)

    Anyone else have any insights?

    I fear I will become a certified network administrator via Google before I figure this out. And I don't want to be a network administrator :)
     
  13. Amdahl macrumors 65816

    Joined:
    Jul 28, 2004
    #13
    MTU size mismatch are a big issue with any tunnel. This can be the fault of your work VPN network, your home router, or (0.1% chance) the ISPs along the way.

    Try lowering the MTU on your network interface to 1450 and see if the problem goes away.
     
  14. lwardwell macrumors newbie

    Joined:
    May 28, 2008
    #14
    VPN Drops

    I have 10.5.6 and it's still an issue. Using MS RDC v2 it will drop within just a few mins. CoRD seems more forgiving but the connection will still freeze and drop randomly.
     

Share This Page