VPN Setting stays ON!!

Discussion in 'iOS 7' started by BvizioN, Oct 11, 2013.

  1. BvizioN macrumors 601

    BvizioN

    Joined:
    Mar 16, 2012
    Location:
    Manchester, UK
    #1
    I do apologise if there is another thread with this subject I could not find....
    But this VPN (Virtual Private Network) stays ON on my iPhone 5. I turn if OFF and in a matter of seconds it turns itself ON! Any suggestion how to get read of this? Thanks.
     

    Attached Files:

  2. big samm macrumors 65816

    big samm

    Joined:
    Oct 27, 2008
    #2
    I use vpn on my iPhone but never had a problem turning it off... That's real weird... Is this hapening on wifi and 4/G?
     
  3. Macman45 macrumors G5

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #3
    I'd try a full restore and see if that clears it..If not then I'd take it in to Apple.
     
  4. BvizioN thread starter macrumors 601

    BvizioN

    Joined:
    Mar 16, 2012
    Location:
    Manchester, UK
    #4
    On both, 3G and wifi! Only started the last few days and just won't go away! Could this result in more battery consumation?
     
  5. Macman45 macrumors G5

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #5
    If it's only just started, then it may be software related...I'd give a restore a shot. As long as you have backups, then you've got nothing to lose by trying.
     
  6. chipmac64 macrumors newbie

    Joined:
    Feb 20, 2012
    #6
    I had the same issue on my iPad. I found that there is another VPN setting in the General Settings area. Scroll done to the bottom of General and you should see a VPN option that says connected. Select this and look at the choose configuration area to see if Connect on Demand is turned on. With this on any time I would use an app that connected to the net the VPN would turn back on. Once I turned Connect on Demand off all is fine. Hope that helps.
     
  7. big samm macrumors 65816

    big samm

    Joined:
    Oct 27, 2008
    #7
    Where is that connect on demand option? I can't seem to find it...
     
  8. Kuwait macrumors member

    Kuwait

    Joined:
    Apr 25, 2012
    Location:
    Kuwait
    #8
    go to your settings > general > VPN. Now tap the little blue arrow next to 'name vpn' and switch off the 'Connect On Demand'.
     
  9. squeakr macrumors 68000

    squeakr

    Joined:
    Apr 22, 2010
    #9
    How does one find the "connect on demand" item? I have never been presented with this option as it just doesn't exist on my device? Could be handy for some things I do and would like to know how to add this option if it is even possible, I am on an original iPhone 5 if it makes a difference (not one of the newer models with the extra bands included).
     
  10. Sheldonsmith macrumors 6502

    Sheldonsmith

    Joined:
    May 14, 2011
    #10
    Mine does not have "Connect on Demand" but I wish it did... iPhone 5s, iOS 7.0.2. WiTopia, Verizon, using IPSec as my only configuration.

    Should I try a PPTP or L2TP for "Connect on Demand" to show up?

    Thanks,

    Sheldon
     
  11. squeakr macrumors 68000

    squeakr

    Joined:
    Apr 22, 2010
    #11
    I am only using L2TP and don't have the option.
     
  12. david91 macrumors regular

    Joined:
    Apr 15, 2015
    #12
    I think that is software related. Check out Express VPN. Could be possible for you to use.
     
  13. ampicillin macrumors newbie

    Joined:
    May 20, 2017
    #13
    Than
    Thanks a lot. It works. I was having the same issue on iPhone 7 plus (Need to connect on blue dot next to VPN name and then options comes up)
     
  14. perwarg13 macrumors newbie

    perwarg13

    Joined:
    May 10, 2017
    Location:
    UK Southampton
    #14
    Glad i found these same problem a while ago. It'd help bigtime
     
  15. derek macrumors newbie

    derek

    Joined:
    Aug 3, 2001
    Location:
    Syracuse, NY
    #15
    I found a second solution, specific to my VPN app and separate from "Connect on Demand" (which I keep OFF). I'm using proXPN's VPN client app. The first setting inside the app is "Connect to proXPN". I turned that OFF. Leave it off. Everything now works as desired. VPN doesn't attempt to connect unless I tell it to inside Settings: VPN.

    One thing I was finding was that having VPN continuously try to connect, while I have WiFi OFF, is that it was creating significant battery drain. I'm glad that's over.
     
  16. CinZen macrumors newbie

    CinZen

    Joined:
    Nov 25, 2017
    #16
    I've been having the same problem and none of the above worked or was available. My solution was found in my security app. I didn't have a connect on demand option either, and couldn't config it to off or manual. With Mac/Apple the majority of my problems are in preferences or software. So it took turning off a few buttons here or there to find that turning off "block ad trackers" gave me the connect on demand option. Keep trying folks. And thanks for helping me know what to look for!
     
  17. Sheldonsmith macrumors 6502

    Sheldonsmith

    Joined:
    May 14, 2011
    #17
    Thank you for bringing up this old thread. I have since moved to VPN Unlimited which now has a Connect on Demand, but would like to have the setup that Derek describes above or having a switch in the control screen.

    One of these days all of this will shake out.
     
  18. CinZen macrumors newbie

    CinZen

    Joined:
    Nov 25, 2017
    #18
    --- Post Merged, Nov 26, 2017 ---
    I have VPN unlimited as well, but the battery drain on my 7 is tremendous with VPN on. And for some reason, it keeps me from setting up some of my smart devices. As long as I'm near a charger, I keep it on all the time. Just another layer of safety. And you are so correct--it all shakes out. And in the interim, we just work around it or find a forum; somebody always has an answer.
     
  19. eiresurg macrumors newbie

    Joined:
    Apr 17, 2018
    #19
    There are two places where VPN is addressed. One is directly under Settings. The other one is under Settings/General. You must click on Settings/General/VPN. Then, click on the blue information bubble next to your VPN service provider.

    [​IMG]

    Then, turn off "Connect On Demand" as shown below. You should be good to go.

    [​IMG]
     
  20. japanime macrumors 68000

    japanime

    Joined:
    Feb 27, 2006
    Location:
    Japan
    #20
    Happy that this old thread was revived. I was having the same trouble and Googled for a solution. and this thread came up at the top of the search results. MacRumors once again comes to the rescue!
     
  21. lasloduncan macrumors regular

    Joined:
    Mar 2, 2015
    #21
    for me just now-- tried all of that- no luck -looked at home screen pulled up pia then turned it off there....if that didnt get it I was going to uninstall it...seems this is the answer for me...again PIA icon on home screen open turn off there.
     

Share This Page