VPN Through Ethernet?

Discussion in 'Mac mini' started by Tminusg, Nov 9, 2012.

  1. Tminusg macrumors member

    Joined:
    Apr 18, 2011
    #1
    Hello all. I've recently acquired a set top box for pandora, and since I live in Canada I do need a prooxy for it to run. I already am subscribed to a VPN service. I do not want all my internet traffic to go through this VPN just the set top box. This box is tethered by ethernet to my mac mini. Is there anybody that knows how to specify a VPN only through the ethernet tethered device through settings in Mac OS X? Any help would be great. Thanks
     
  2. James950 macrumors newbie

    Joined:
    Jan 3, 2014
    #2
    ^ strong bump.

    I'm also in need of a solution for this and haven't come up with much.
     
  3. mdelrossi macrumors member

    Joined:
    Jun 22, 2005
    #3
    Does the set top box have wifi?
    If so vpn via ethernet and send the traffic out of the mini wifi to the set top box.
     
  4. James950 macrumors newbie

    Joined:
    Jan 3, 2014
    #4
    I'm in kind of the same situation, but not exactly the same situation. I have my iMac connected to my router via wifi, i then have another device connected to my iMac's ethernet port sharing my wifi connection. I then have a VPN setup using PPTP. Basically, what i am trying to do is i would only like the ethernet connection on my iMac using the VPN ONLY where as the wifi i would like it not to use the VPN and use my default network settings.

    Ethernet > VPN
    Wifi > normal connection.

    At the moment the wifi is using the vpn, and the ethernet is using the vpn as its sharing my wifi connection. I would just like the ethernet connected to my iMac to use the VPN only. So the question is: is there anyway that the VPN connection can only be enabled for the ethernet only?

    Guess my question probably would be better off in the iMac section.
     
  5. James950 macrumors newbie

    Joined:
    Jan 3, 2014
    #5
    Doesn't matter, Found a solution which seems to have fixed it. All i needed to check was 'create computer-to-computer networks' on the wifi setting and on the VPN uncheck 'Send all traffic over VPN connection' on advanced button.

    Then it connected to my router normally while the ethernet went through the VPN.

    [​IMG]
     

Share This Page