iPhone XS w/ eSim on AT&T: SIM failure and no service & Number changed to primary (SMS) & iMessage issues

OverSpun

macrumors 65816
Original poster
Sep 12, 2006
1,066
74
California
Last week I thought I mainly needed the iOS 12.4 update. After some time, service came back. However, today I completely lost service including “no sim” “no service” and “sim failure”. Obviously the 12.4 did not help anything.

At this point I can only use WiFi. I live in SoCal, is anyone else dealing with this as well? Preferably if anyone knows a way to fix it.

I still have my eSim card and SIM card as well, have not needed the physical SIM in the phone since I got the eSim in December ‘18. Zero issues until recently.

Thanks
 

OverSpun

macrumors 65816
Original poster
Sep 12, 2006
1,066
74
California
Without service all day, I just reset the network and hard reset the phone.

Under Cellular “Turn On this line” it was off, I turned on the switch and a second screen let me activate my primary line and I have “some” service, only 1 bar but that’s a lot better than nothing.

5Ge is worse than LTE since ATT started this. I feel that att caused this service failure today.
 

OverSpun

macrumors 65816
Original poster
Sep 12, 2006
1,066
74
California
I still have intermittent service with No SIM, SIM failure, No Service. The phone has not worked normally since last week.
 

OverSpun

macrumors 65816
Original poster
Sep 12, 2006
1,066
74
California
I have resolved two issues and it only needs 1 post. I figured the no service issue myself by redoing my eSIM, Apple helped me to figure out the other issue. After a lot of research and nothing else resolved any of these issues before.

1. I removed and readded my eSIM and it seems to have resolved AT&T's 5Ge "upgrade". This may or not caused an iMessage issue and it stopped syncing between my MBP / Watch & Phone. I could only send SMSs from my phone.

2. "Waiting for activation" notification by turning on and off the iMessage trying to resolve the "waiting for activation" and making iMessage work again,

This can be resolved by going to the settings -> General -> Reset -> "Reset all Settings". You will need to redo your wallpaper, Face ID, Wallet cards, Control Center, Activate Locations, atrial fibrillation (If you have Watch 4) and WIFI and about nothing else.

My phone is still showing "Number changed to Primary" by sending or receiving SMSs. I'll make a post if I can figure it out.
 
Last edited:

idgsd

macrumors newbie
Aug 29, 2018
12
3
California
Sorry to revive an old thread. I was battling this odd intermittent issue of my iPhone XS with AT&T esim losing carrier and having a hard time getting the carrier back. Tried all the tricks, airplane mode on/off, phone on/off, reboot, network reset, etc. At time it will regain network just to lose it again (after a week or so) with No Sim or Invalid Sim at times. Called Apple Customer Service for naught, AT&T resets my line and it worked for a day or two. Finally got tired of it when it happened again last week, went to an AT&T store (few are still open) and got a physical sim card and will deal with the issue when life is back to normal. Searched the web and it seems like a real issue. The common to the few reports are iPhone XS (XS Max), esim, and AT&T.
 

Cegonzalezc

macrumors newbie
May 17, 2020
1
0
I am having the same issue running iOS 13.4.1 on an iPhone 11 Max Pro with ATT e-sim failure. Tried installing a new esim but the system will not let me stating that it is unsupported. I can’t even see a second line now when I go into settings>cellular.
 

idgsd

macrumors newbie
Aug 29, 2018
12
3
California
Interesting....Haven’t had any issues with my physical sim since I swapped my esim. Since I don’t expect to travel Internationally for a while, I see no reason to go back to esim anytime soon. When you get your issue resolved, I would appreciate an update.
 

nathanjbrown

macrumors 6502
Apr 9, 2008
262
47
Santa Barbara, CA
I've been on the phone with AT&T for more than an hour (in total) this past week. I'm not getting any service on my eSIM (which worked fine for nearly a year) and various reps at AT&T are perplexed. The number associated with the physical SIM is working fine. One odd "clue" they're seeing on my account is that my two phone numbers are showing two different versions of iOS. One is 13.4.1 and the other is a previous version. That's apparently an oddity given that both numbers should reflect the same iOS version as both numbers are bonded to the same device (iPhone XS). Has anyone found a resolution for this? I'm about to call Apple... Thanks!
 

idgsd

macrumors newbie
Aug 29, 2018
12
3
California
My thought at the time, when it first happened, was to get my iPhone XS fully diagnosed at the local Apple store. Unfortunately the stores just closed. If there is an open Apple store nearby (the stores just opened, or about to open, here in San Diego) I recommend you get a full diagnostics at the store. When I called them at the time, they were unhelpful and sent me to AT&T. My second Sim (physical at the time) was an international Sim I use often when on vacation (I recharge it there). I removed it and replaced my AT&T eSim (my main account) with a physical Sim. No problem since.
 

idgsd

macrumors newbie
Aug 29, 2018
12
3
California
I've been on the phone with AT&T for more than an hour (in total) this past week. I'm not getting any service on my eSIM (which worked fine for nearly a year) and various reps at AT&T are perplexed. The number associated with the physical SIM is working fine. One odd "clue" they're seeing on my account is that my two phone numbers are showing two different versions of iOS. One is 13.4.1 and the other is a previous version. That's apparently an oddity given that both numbers should reflect the same iOS version as both numbers are bonded to the same device (iPhone XS). Has anyone found a resolution for this? I'm about to call Apple... Thanks!
What was the resolution of your case? A similar situation with my wife’s iPhone XS. Went to an AT&T corporate store and they couldn’t fix it and redo the esim. The only solution was to put in a physical sim (instead of an unused international sim she had there for a “safe keeping”). I had a somewhat similar situation with an iPhone XS, described elsewhere in the present conversation. I also converted to a physical sim, but recently got a new esim without any issues since. AT&T tried unsuccessfully to redo my wife’s esim. I think something is really flaky with iPhone XS and esim with AT&T.
 

clunkmess

macrumors 6502a
Jul 28, 2011
588
415
California
This is happening to me now too. iPhone 11 Pro eSIM on AT&T. i was without service for nearly 4 hours today and nothing i did would bring it back. I’ve never had this issue until a couple days ago.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.