W7 Enterprise boot camp driver support? -- Solved :)

Discussion in 'Windows, Linux & Others on the Mac' started by ChocoboNL, May 3, 2010.

  1. ChocoboNL macrumors member

    Joined:
    Feb 20, 2008
    #1
    Hello Everyone,

    The situation: So I just got a new shiny MBP 13" (standard base-line configuration) and am in the process of getting this thing loaded up with my needed applications and files.

    So, a new machine and time for a new Windows version, I had W7 RC on my old MacBook and it worked fine (drivers included). Now I was able to get a W7 Enterprise edition via my university and the installation was quite easy - I had to format my BOOTCAMP partition during the installation since it was not the proper filesystem though - and the installation was successful. Hurray!
    That means it's now time for some problems!

    The problem: Windows is great on a MacBook, given that the BootCamp Drivers are working. Frankly, the cd that came with my MBP did not get recognized, however, I already had a retail Snow Leopard cd and that did get recognized.
    The problem, now, is that the install fails with the message that: "Boot Camp x64 is unsupported on this computer model".

    The suspect: Now, I suspect that this might have to do with my copy of W7 being the Enterprise edition, and this was not listed in the bootcamp assistant as one of the supported versions of W7 - it specifically stated "Home Premium, Proffessional, Ultimate".

    The question(s): Can anyone confirm wether or not W7 Enterprise edition is incapable of installing bootcamp drivers? If so, is there a known solution? - I didn't find any W7 Enterprise related threads - And if not, what, then, could be the real problem?

    The (a) solution: Seems like it W7 Enterprise - along with several other versions of windows - was indeed unsupported and caused the trouble, information in this thread helped me solve the problem.
    Shortly, I browsed to the apple drivers on the dvd and manually installed them using the 'Bootcamp64.msi' file and leaving 'setup.exe' untouched. I needed some extra permissions so I chose 'troubleshoot compatibility' from the file's contextual menu - presto! :)

    Thanks for your help!
     
  2. balamw Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #2
    Try installing BootCamp64.msi manually. (EDIT: http://mroogle.*************/ and type BootCamp64.msi).

    B
     
  3. ChocoboNL thread starter macrumors member

    Joined:
    Feb 20, 2008
    #3
    Thanks, I'll look in to this and report back afterwards. ;)
     

Share This Page