Wacky AirPort hijinks

Discussion in 'Mac Basics and Help' started by Objectivist-C, Nov 7, 2007.

  1. Objectivist-C macrumors 6502

    Joined:
    Jul 1, 2006
    #1
    I've suddenly lost the ability to connect to the wireless network at my workplace. The network configuration hasn't changed, and no one else is having issues. I've tried re-booting and power-cycling the router to no effect. This is what gets printed to the console:

    Code:
    Nov  6 23:00:52 iBookG4 airportd[117]: Error: Apple80211Associate() failed -6
    Nov  6 23:00:52 iBookG4 SystemUIServer[91]: Error: airportd MIG failed = -6 ((null))  (port = 67643)
    Nov  6 23:00:53 iBookG4 airportd[117]: Error: Apple80211Associate() failed -6
    Nov  6 23:00:53 iBookG4 SystemUIServer[91]: Error: airportd MIG failed = -6 ((null))  (port = 67643)
    If I try joining from the menu that pops up after waking from sleep, I get a message saying the attempt to join the network has timed out. If I go through the diagnostics in Network Assistant, it says the network is passworded (it isn't).

    I don't think it's likely to be a Leopard issue as the connection worked fine until tonight. Any ideas?
     
  2. compuwar macrumors 601

    compuwar

    Joined:
    Oct 5, 2006
    Location:
    Northern/Central VA
    #2
    Set the MTU to 1492 and see if that works ("sudo ifconfig en1 mtu 1492" from the command line.)
     
  3. bluncle macrumors newbie

    Joined:
    Nov 7, 2007
    #3
    I'm seeing the exact same behaviour on a brand new imac I just got. setting the MTU value did not help. any other thoughts?

    thanks in advance. it's too late at night to call apple-care.
     
  4. tmailander macrumors newbie

    Joined:
    Jul 1, 2007
    Location:
    San Diego, CA USA
    #4
    Leopard...Airport...Applecare

    Post if you actually get through on this issue to AppleCare. I've sat in long telephone cues with no response.
     
  5. bluncle macrumors newbie

    Joined:
    Nov 7, 2007
    #5
    Ok, after 40min on hold at apple care and a lengthy but friendly tech support, my problem got fixed.

    All we did was a PMU-reset (turn mac off, remove all usb-plugs and all powersupplies, wait 10sec, then press the power-on button, wait a few secs and plug in power, keyboard etc.) and a pram-reset (power the mac on while holding down apple+comand+r+p and wait for 3 chimes)

    that fixed it
     
  6. Objectivist-C thread starter macrumors 6502

    Joined:
    Jul 1, 2006
    #6
    Either manually setting the MTU worked, or it spontaneously resolved itself. Thanks, folks.
     
  7. cog6231 macrumors newbie

    Joined:
    Sep 21, 2008
    #7
    Network Lost from Keychain

    I had the same problem. In my case I could no longer access my home network. It has encryption and does not broadcast the SSID. When I would log in, the connection would come up for about three seconds and then go down. Looking in the console log revealed 'Apple80211Associate() failed -6' errors. Curiously, if I changed my wireless network to broadcast the SSID, it stayed connected without a problem. Changing the MTU did not help me; neither did resetting the PRAM or PMU.

    I decided to delete the entry for the network from my keychain and see if that would help, but when I looked there it was already gone. All my other Airport keys were there. This was especially strange since I saw the SSID in the console log, so something new about the network. I manually connected, told it to remember so that it added it back to the keychain and have not had any problems since.

    I have card type 0x14E4, 0x4E with firmware version 'BCM43xx 1.0 (4.170.25.8)'.
     
  8. tF39 macrumors newbie

    Joined:
    Aug 29, 2009
    #8
    Error: Apple80211Associate() failed -6

    We were also receiving the "Error: Apple80211Associate() failed -6" error message.

    In our case we couldn't connect:
    1. wireless
    2. wired with the airport configuration utility (it sees the airport but doesn't read the config)
    3. when rebooting

    In our case it was temporary solved, by:
    1. turning off the airport + usb connected disk
    2. attach and power the usb disk to a mac
    3. wait for several minutes until the disc (being repaired) finally mounts on the desktop
    4. eject the usb disk
    5. reconnect and power the usb disc to the airport extreme again
    6. now power up the airport extreme itself

    The only problem is that these problems repeats within approximately 1 week.
     
  9. alainehoweth macrumors newbie

    Joined:
    Sep 7, 2009
  10. richmondimage macrumors newbie

    Joined:
    Aug 17, 2010
    #10
    I had all these problems. My wireless signal stopped frequently, more so on battery power or when the computer was hot. Had to restart to reconnect and occasionally airport wouldn't turn on until I restarted a few more times. Tried resetting PRAM & PMC, added a new location and reset DHCP, deleted my config files, changed wireless channels. I use a Time Machine with WPA/WPA2 personal security and eventually I took all security off my router and everything seems to work fine for the moment. I made the network closed so people can't see it. Until there is a permanent solution this will have to do.

    IT HAS BEEN 3 HOURS AND NO MORE PROBLEMS SO FAR
     

Share This Page