wacom driver

Discussion in 'macOS' started by al404, Sep 1, 2016.

  1. al404 macrumors 6502

    al404

    Joined:
    Apr 24, 2011
    Location:
    Novara, Italy
    #1
    Hi

    Just find out that wacom closed the forum, at list for a while

    I have a wacom intuos pen & touch


    is a 2013 model, i upgrade from bamboo to that a couple of years ago

    IMHO wacom driver upgrade system make me look for a new driver every X months since driver doesn't upgrade on it's own as most of the software does

    Now wacom released a "new" model that looks different but it is almost the same that i have, as the intuos i have is almost the same of previous bamboo one

    on wacom drivers page my tablet is not listed
    http://www.wacom.com/support/product-support/drivers
    but clicking on the link in Intuos raw i end up into this page
    http://www.wacom.com/en-gb/support/intuos-support

    my tables doesn't seem compatible with latest driver, i was wondering if is just not listed or if they stop updating driver forcing user to upgrade to newer tablet

    i had a lot of issue with wacom drivers in latest 4/5 years that i'm using them, and they are not really quick updating them

    I guess there is no better alternative at wacom tablets
     
  2. rudo.ba macrumors member

    Joined:
    Jun 28, 2013
    #2
  3. al404 thread starter macrumors 6502

    al404

    Joined:
    Apr 24, 2011
    Location:
    Novara, Italy
    #3
    i saw it, so is not going to get updates? latest for other intuos is 6.3.17-5
     
  4. rudo.ba macrumors member

    Joined:
    Jun 28, 2013
    #4
    I have the same model, and think there were some updates this year (this one on web is listed as 12/21/2015). Try updating from wacom utilities (or so, in your /Application/Wacom folder). Not at hand now, tomorrow i look what version of driver is in my work mac.
     
  5. al404 thread starter macrumors 6502

    al404

    Joined:
    Apr 24, 2011
    Location:
    Novara, Italy
    #5
    from wacom center it said that i can update my driver to 6.3.17-5 they seem to work ok so far
     

Share This Page