Waiting for Activation?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by cheesus182, Sep 15, 2011.

  1. cheesus182 macrumors newbie

    Joined:
    Sep 15, 2011
    #1
    Hey guys.

    Two questions.

    1. I restored my iPhone 3GS (FW 4.21) a couple of days ago and since then its been giving me the notification: "Waiting for Activation. This may take some time"
    How do I activate my phone then? Im not getting any service at all now? The odd thing is, I have had my phone for over a year and it hasnt said this up until now?

    2. Is there anyway to litterally delete the entire firmware of the iPhone and install a completely new one? Not just restoring but actually deleting it off the phone so that the phone is just 100% hardware and no software on it anymore?

    Thank you very much!
     
  2. Saileshbreaker macrumors regular

    Joined:
    Aug 13, 2011
    #2
    The latest firmware for your device is 4.3.5
    Download it and put your phone in DFU (google for it)
     
  3. Kyotoma, Sep 15, 2011
    Last edited: Sep 15, 2011

    Kyotoma macrumors 68000

    Kyotoma

    Joined:
    Nov 11, 2010
    Location:
    Carnegie and Ontario
    #3
    This.

    I am surprised that it has been taking that long to activate it, but it does sounds more software related rather than hardware.

    You might be able to restore down to 4.1, as I believe that Apple is still signing 4.1 for the 3GS. Then if you've ever jailbroken and saved your SHSH blobs for 4.2.1, you could then shift+restore back to 4.2.1 using a fresh firmware download, of which you should be able to find on iclarified's website.

    EDIT: I forgot to mention that in order to restore to 4.2.1 using SHSH blobs you'll need a program called TinyUmbrella. There are downloads as well as a tutorial for this method on iClarified's website.
     
  4. cheesus182 thread starter macrumors newbie

    Joined:
    Sep 15, 2011
    #4
    Thanks guys but ive tried restoring to 4.1 already and it hasnt worked.

    The problem is, my 3GS came with the iPad baseband, hence I can not update to 4.3.5
    If it was up to me, I would update to 4.3.5 with out a jailbreak or anything but the iPad baseband has made this impossible!

    Anything I can do?
     

Share This Page