Waiting For Activation

Discussion in 'iPhone' started by rickytowner, Jul 12, 2009.

  1. rickytowner macrumors member

    rickytowner

    Joined:
    Apr 9, 2008
    Location:
    UK
    #1
    So my brother just brought a 3G 16gb from the market.

    So we just connected it to iTunes and updated to 3.0 and put his sim into the phone, and for the past hour the 'Waiting For Activation, This may take a while' box has been on the screen, and there is no network connectivity what so ever :confused::confused::confused:

    Could any of your guys help me?
     
  2. paulsalter macrumors 68000

    paulsalter

    Joined:
    Aug 10, 2008
    Location:
    UK
    #2
    As far as I can remember it needs an activation signal from o2, so if you have no signal you will never get this

    Are you in a good signal area ?
    Does the sim work in another phone ?
    Is it an o2 sim ?
     
  3. rickytowner thread starter macrumors member

    rickytowner

    Joined:
    Apr 9, 2008
    Location:
    UK
    #3
    Yer my iPhone is next it it and i have full 3G signal.
    Yep the sim works fine in my phone and my bros old phone.
    And yer its a o2 pay as you go sim :)

    :confused::confused:\

    Thanks for your help in advance
     
  4. ZipZap macrumors 601

    Joined:
    Dec 14, 2007
    #4
    You need to call them as there will be no magic signal.

    O2 or ATT need to provision your phone. I waited 16 hours...time wasted because it was never going to activate.

    Call them.
     
  5. Drewsky87 macrumors 6502

    Drewsky87

    Joined:
    Dec 5, 2008
    Location:
    MD
  6. rickytowner thread starter macrumors member

    rickytowner

    Joined:
    Apr 9, 2008
    Location:
    UK
    #6
    tried loads of reboots and when we called o2 they said take it to an o2 store and when we took it there they said to call o2 :confused::confused::confused: so we dont know what to do
     

Share This Page