Wake-from-sleep and graphics fan issues in 10.14.4

Discussion in 'Mac Pro' started by cdf, Apr 10, 2019.

  1. cdf macrumors 6502

    Joined:
    Jul 27, 2012
    #1
    I am wondering if anybody else is experiencing this issue. With a clean install of 10.14.4, my cMP consistently wakes up to a black screen. To get an image, I must power cycle the display. Also, after waking up, if my RX 580 is mildly stressed (like after scrolling pages in Safari) its fans momentarily spin up (quite louder than in 10.14.3) and then spin down (annoyingly pulsating in synchronism with my scrolling). Before sleep, the card behaves normally. I've gone back to 10.14.3 and everything there is fine.

    Would anybody have any experience with troubleshooting such an issue?
     
  2. PowerMike G5 macrumors 6502

    Joined:
    Oct 22, 2005
    Location:
    New York, NY
    #2
    I've noticed I've had some random wake-from-sleep issues with my Vega Frontier Edition in 10.4.4 that I haven't had before. Just like you mentioned above. I haven't been putting it to sleep and will troubleshoot further.
     
  3. MevetS macrumors newbie

    MevetS

    Joined:
    Dec 27, 2018
    Location:
    Earth
    #3
    It happened to me once. I unplugged the monitor from the power strip, waited a bit, plugged it back in, rebooted the system, and haven't had an issue since; over two weeks since it happened. I've been on Mojave for three months or so.
     
  4. Patrice Brousseau macrumors member

    Joined:
    Dec 14, 2016
    Location:
    Montréal, Canada
    #4
    GPU fan problems documented since February on... ahem... Hackintosh forums. Related to 10.14.4 and occurring right after sleep. In my case...ahem again...on my Hackintosh: GPU fans higher after sleep, experienced on MSI Radeon RX560 and 580. Some users relates behavior like yours, fan pulsating following scrolling...

    To resume what's happening to me, GPU fan (in case of RX560) is running at 19% at boot and remains at 24% after sleep, independently of the GPU temp. One user said that latest 10.14.5 beta didn't fixed it for him.
     
  5. cdf thread starter macrumors 6502

    Joined:
    Jul 27, 2012
    #5
    Thanks for letting us know. For your sake, since this is happening on real Macs, there is hope that this bug gets reported to Apple. Unfortunately, being on a flashed 4,1 machine, I'm not really in the position to report the bug.

    Would anybody with a real 5,1 care to look out for this bug and maybe file a report?
     
  6. Patrice Brousseau macrumors member

    Joined:
    Dec 14, 2016
    Location:
    Montréal, Canada
    #6
    It looks like 10.14.5 beta 2 solves this bug. Didn't tried myself but some reports that replacing AMD drivers with the beta 2 versions is a way to circumvent this behavior...
     
  7. cdf thread starter macrumors 6502

    Joined:
    Jul 27, 2012
    #7
    Thanks. I tried the beta today and can confirm that the fan issue is resolved.
     
  8. cdf thread starter macrumors 6502

    Joined:
    Jul 27, 2012
    #8
    Although the fan issue is fixed, display wake is still problematic. I have investigated the issue further and have identified the culprit to be the DisplayPort 1.2 connection. With DP 1.1 or HDMI 2.0, my display wakes up properly as it did in 10.14.3. Apple is apparently doing quite a bit of work in the graphics department...
     

Share This Page

7 April 10, 2019