Wake on Wifi - is anyone having success?

Discussion in 'Apple TV and Home Theater' started by bluewooster, Oct 9, 2012.

  1. bluewooster macrumors member

    Joined:
    Jul 18, 2007
    #1
    Hi - I know there is quite a lengthy thread that pertains to this topic. I've read through it but wanted to pose the question slightly differently.

    Is anyone actually having any success waking their itunes server from their apple tv? Put another way, is anyone able to allow the computer hosting itunes to sleep and then still access their homesharing/movies/etc? Despite many trials, I cannot. Once my computer goes to sleep, my homesharing disappears and I can no longer see my library.

    I believe I actually had this at one point (maybe when I had an atv2 and snow leopard?) but have been unable to reproduce it. I have Lion set to "Wake on Wifi" in energy settings. According to the apple website, I need an airport router (which I'm not using) to enable this function, but reading through these forums, I'm not so sure that will help.

    Thanks in advance. Once again, I appreciate that this is a topic that already has a mature thread. However, I'm more interested if anyone actually does have this feature working and, if so, what they are using (atv2, 3, what computer, what OS, ethernet, wifi, etc).
     
  2. orestes1984 macrumors 65816

    Joined:
    Jun 10, 2005
    Location:
    Australia
    #2
    I could go down the route of use the product as intended as that was the last response to a thread that I participated in in this particular forum, yet somehow I don't think you will get the same response :rolleyes:

    The simple answer is you need a device that is capable of sending a magic packet to the server... Bonjour devices do it, but otherwise you will need a physical connection to your network and a program capable of doing the same thing, there's a couple for OS X with one being called Wake On LAN or something similar.

    I'd suggest in future that you don't come on MacRumors to tell everyone that Apple is not perfect :rolleyes:
     
  3. jamesvdm macrumors regular

    jamesvdm

    Joined:
    Mar 28, 2011
    Location:
    Perth, Australia
    #3
    That would eliminate 99% of posters!

    On topic, no, WOL/magic packet/whatever you want to call it has not worked on my Mac mini since 10.6.
     
  4. orestes1984 macrumors 65816

    Joined:
    Jun 10, 2005
    Location:
    Australia
    #4
    I know right :rolleyes: Magic Packets don't work because Apple believes Bonjour is the coolest :rolleyes:
     
  5. bluewooster thread starter macrumors member

    Joined:
    Jul 18, 2007
    #5
    I guess I'm really trying to determine if replacing my (seemingly fine) router with a (seemingly expensive) airport would solve the problem. It looks like many people on that other thread about home sharing do have an airport and are unable to get this working either! Also, one post on that thread suggested that an ATV provides the same Bonjour functionality as an Airport so I'm not sure if it would be redundant.

    My ATV is linked via Ethernet and I don't think I've ever tried moving my iTunes server so it is linked via Ethernet as well - I think I'll experiment with that tonight. However, if I read the tone of your responses correctly it sounds like this is a feature that "just doesn't work" right now (no pun intended), correct?

    By all means - if buying an airport would fix it, I'd happily do so! I don't like having the computer awake all the time and running to the other room to wake it each night is also annoying!
     
  6. orestes1984 macrumors 65816

    Joined:
    Jun 10, 2005
    Location:
    Australia
    #6
    Try this from a Mac on your network http://www.readpixel.com/wakeonlan/. My tone of voice is in response to certain other posters on this forum, you'll have to read between the lines at the moment to decipher the otherwise helpful post, it's not directed at you.
     
  7. bluewooster thread starter macrumors member

    Joined:
    Jul 18, 2007
    #7
    Thanks for the info Orestes1984! And no worries - by "tone" I only meant that I sensed some light friendly sarcasm which leads me to believe I may try a multitude of suggestions to only end right back where I am (with a computer unable to be woken by my ATV!).
     
  8. orestes1984, Oct 10, 2012
    Last edited: Oct 10, 2012

    orestes1984 macrumors 65816

    Joined:
    Jun 10, 2005
    Location:
    Australia
    #8
    I don't know whats going on with Lion/Mountain Lion, I here that its broken something and only Bonjour can do magic packets, which is another thing I hate about the Mac ecosystem. When Wake On Lan is a perfectly acceptable industry standard, Its just like M4V containers when the industry standard is MP4 and the fact Airport Extremes don't interact well with other routers... I have one here that is effectively useless unless I hardwire it into my network via ethernet cable.

    I'm not sure whether an Airport will fix your problem... I don't run Mountain Lion, I never did like the Lions, I'm a power user so I'm happy doing everything myself just fine on Snow Leopard and am not a fan of the iOS styled features of either OS update. Perhaps you can consider downgrading? I'm perfectly happy running Snow Leopard which does magic packets just fine, my server is still a PPC Mac running Leopard.

    I've been using Macs for 15+ years and I'm starting to develop a real love/hate relationship with the way Apple is going as a company.
     
  9. waw74 macrumors 68030

    Joined:
    May 27, 2008
    #9
    i don't have my express up and running right now, so i can't check out wake on wifi, but it runs what is called a "bonjour sleep proxy" what that does is keep track of all the bonjour devices on the network, when they go to sleep, the express continues to broadcast the bonjour services of the sleeping machine. if another device starts to look for that service on the network, the express will send the magic packet to wake the sleeping device.

    without an airport (express or extreme) on your network, the bonjour services disappear when the computer goes to sleep.

    if you can think of a place you want wireless speakers, you could get an express and hook them up that way. it's a bit cheaper than the extreme.

    a small side effect of the sleep proxy is that your sleeping devices will wake up periodically, the express will wake them up to make sure they are still there and the services are still running.

    a regular industry standard magic packet will wake a mac, i use a command line client on my linux box to wake a sleeping (hardwired) mac mini.
     
  10. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #10
    Your Apple TV should (not saying it is, just that it should) act as a Bonjour Sleep Proxy. As someone else has mentioned, it uses the industry standard magic packet to wake your mac.

    http://en.wikipedia.org/wiki/Bonjour_Sleep_Proxy

    I happen to use an Airport Extreme(first Gigabit version), my Macbook Air(Mountain Lion) always shows up in the Apple TV(3) List whether it's awake or not, and wakes up if need be.

    A.
     
  11. angelsguardian macrumors regular

    Joined:
    Jun 11, 2012
    Location:
    North East Scotland
    #11
    Now I have a 5th gen Airport Extreme my ATV's wake my iMac iTunes server which they never had before. BUT if the server goes to sleep via schedule or power button (rather than from energy settings) then it won't wake from ATV. A rather ridiculous situation to need an Apple router to do this but that seems to be the key.
     
  12. GarrettL1979 macrumors 6502

    Joined:
    Feb 15, 2012
    #12
    This has never worked for me-- I just gave up. I have a new AEBS, 2011 MBP, and an ATV 3.

    That said, streaming got a whole lot faster once I replaced my old Linksys with an AEBS.
     
  13. EmpyreanUK macrumors regular

    Joined:
    Mar 6, 2011
    #13
    I have an AirPort Extreme, a 2011 iMac and an Apple TV, and it has never worked properly.

    At least in my case, the problem is that my iMac is unable to maintain its registration with the sleep proxy. This is something I've long suspected and have since confirmed.

    The Mac goes to sleep as per the settings in Energy Saver. It will then conduct maintenance wakes, wherein the Mac will periodically wake up (ever 60–90 mins) to renew its sleep proxy registration, successfully. Yet at some point, the registration will fail during one of the maintenance wakes. Sometimes it succeeds several times before failing, sometimes the failure happens early on. I haven't been able to make out any pattern. But it has never not failed over the course of, say, 12 hours. And once sleep proxy registration has failed once, the Mac will not schedule a further maintenance wake, meaning that it will not make any further attempts to register itself.

    I've been able to locate the function in mDNSresponder that is issuing the error message always present in the system log after the failed proxy registration, but I'm not a programmer and so don't know how to take my investigation any further. And nor should I be able to, since this is an advertised feature that was one of my main reasons behind my purchasing of an iMac.
     
  14. alFR macrumors 68020

    Joined:
    Aug 10, 2006
    #14
    If you haven't already, you should report it as a bug to Apple via http://www.apple.com/feedback/ and include the relevant bits of the error log in your report. At least then there's a chance of it getting fixed.
     
  15. bluewooster thread starter macrumors member

    Joined:
    Jul 18, 2007
    #15
    Thanks all for the info - i suspect an airport won't solve my problems but I may get one to trial anyway. If it doesn't help, I can always return it. I may try reinstalling Snow Leopard as well - I could swear this used to work for me in the past under Leopard (it was one of those features I never thought about until it stopped working!)
     
  16. EmpyreanUK macrumors regular

    Joined:
    Mar 6, 2011
    #16
    As others have mentioned, it's unlikely that getting an Airport will solve your problem, as your Apple TV performs as a Bonjour sleep proxy, and especially as you report that the wake for network feature worked for you under Snow Leopard. I've seen it mentioned by other people in threads on the same topic that it once worked on 10.6 but ceased to do so after an upgrade to Lion or Mountain Lion, so it would appear to be a bug on the Mac end introduced in 10.7.
     
  17. EmpyreanUK macrumors regular

    Joined:
    Mar 6, 2011
    #17
    I have submitted a bug report in the past, but upon reading your post I realised that I haven't done so since discovering the error message in the log and subsequently isolating it to the relevant file in the mDNSresponder package.

    I've just written a pretty extensive bug report, and have hopefully not omitted any details.

    Hopefully somebody will read it.
     
  18. pavelbure macrumors 6502a

    Joined:
    Feb 22, 2007
    #18

    Ever since 10.7 I have been unable to wake my mac when trying to go over 3g using my phone, but when on wifi it works.
     
  19. EmpyreanUK macrumors regular

    Joined:
    Mar 6, 2011
    #19
    Is this using LogMeIn or something similar?
     
  20. pavelbure macrumors 6502a

    Joined:
    Feb 22, 2007
    #20
    I use mocha vnc lite or remoter vnc.
     
  21. EmpyreanUK macrumors regular

    Joined:
    Mar 6, 2011
    #21
    Perhaps you're already aware of and have addressed this, but OS X Lion introduced a feature called 'Darkwake'. This meant that, when the Mac woke up for network access, it would only do so in a low-power state, in which only basic services were available (disc access, network access, etc.). Apple services would be available (screen sharing log-in, file sharing etc.), but any third-party services aren't available in this state.

    Darkwake can be disabled easily enough, and as far as I know, when it's turned off the Mac should perform a 'full' wake for network access, meaning that third-party applications (i.e. your VNC app) would be available.
     
  22. pavelbure macrumors 6502a

    Joined:
    Feb 22, 2007
    #22
    That looks like it may help me. But everything I have found to turn that off involves editing in the terminal, which I'm not that great at.
     
  23. EmpyreanUK macrumors regular

    Joined:
    Mar 6, 2011
    #23
    If you're not totally comfortable with fiddling around in Terminal, then darkwake can be disabled by editing the relevant .plist finder in TextEdit. I direct you to page 2 of a thread about WOL problems on OS X 10.7 which has instructions and some other remarks on disabling darkwake:

    http://forums.macrumors.com/showthread.php?t=1195152&page=2

    The benefit of doing it this way, instead of through the terminal, is that you actually know what you have changed (you're editing a file directly, rather than issuing obscure system commands), and it is thus very easy to reverse those changes.

    If you decide to have a go at disabling darkwake following the method I linked to, be sure to make a copy of the .plist file (com.apple.Boot.plist) before you make any changes. Simply right click, Copy, and then paste to somewhere like your Documents or Desktop folder. That way, if the changes don't solve your issue, or you run into any other problems, you can simply paste your copy of the original file over the modified version.

    Good luck!
     
  24. pavelbure macrumors 6502a

    Joined:
    Feb 22, 2007
    #24
    I did that, now the problem is my machine will not stay asleep. so at night when I put it to sleep it will just wake a few minutes later and stay on all night.

    Damned if I do, damned if I don't now.
     

Share This Page