Wake reason: RTC (Alarm) - how to deactivate?

Discussion in 'OS X Yosemite (10.10)' started by tyhunter, Aug 19, 2014.

  1. tyhunter macrumors newbie

    Joined:
    Aug 19, 2014
    #1
    Hello guys:
    my Yosemite works fine on my laptop(Acer V3-571g).
    My problem is that Yosemite wakes up automatically roughly every 2 hours for 10 minutes and then goes back to sleep.
    It sounds like the PowerNap feature, but I have not activated that (it doesn't show up in Energy Saver preferences anyway).
    I try to add Darkwake=0 in org.chameleon.Boot.plist of Chameleon r2391,but it doesn't work,so i try to reset my BIOS,and turn off "Wake From Lan",but it doesn't work.
    Today I updated the DP6,but seems that apple don't fix this problem.

    Do you have any clues how I can deactivate those RTC Alarm wakes?

    Thanks!

    PS: Sleep works fine in Mavericks without any RTC Alarm wake ups
     
  2. Gary King macrumors 6502

    Joined:
    Jun 14, 2004
    #2
    I've got this problem too, with the first stable release of Yosemite. Did you ever manage to find a solution?
     
  3. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #3
    Same here. All appropriate switches are turned off in System Preferences/pmset, but wakeup still occurs every ~2 hours.

    A.
     
  4. Mitch Pollock macrumors newbie

    Joined:
    Oct 18, 2014
    Location:
    Somewhere in mainland Europe
    #4
    I've got the same issue here. The only piece of advice I could google was disable the "Wake for network access" option. It has no effect here. I've also checked that I have all sharing options disabled. Couldn't find what else could be there to wake my iMac from sleeping.
     
  5. IEatApples macrumors 6502a

    IEatApples

    Joined:
    Jan 26, 2004
    Location:
    Northern Hemisphere (Norway)
    #5
    I have the same problem with my Mac Pro (2008).
     
  6. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #6
    Amusingly, my Macbook Air (which has wake/powernap/etc. enabled) did not wake up all night.

    A.
     
  7. Mattww macrumors 6502

    Mattww

    Joined:
    Jan 11, 2008
    #7
    Same here with a Mac Pro 2009.

    I've checked wake on network access is off and no schedule set. Also done a SMC reset and PRAM reset.

    Only started after installing 10.10 upgrade over 10.9.5.
     
  8. Goldfinger macrumors 6502

    Joined:
    Jan 7, 2006
    Location:
    Belgium
    #8
    Came here to post about the same issue. Mac Pro 2010. It's happening since the first public beta. I did a clean install after the public release. Didn't help. I also tried resetting the PRAM and SMC. No dice.
    I've also reported it countless times during the beta period.

    It's driving me mad and makes sleep essentially useless for me.
     
  9. Mattww macrumors 6502

    Mattww

    Joined:
    Jan 11, 2008
    #9
    I do remember wake on network access being automatically turned on for me when either updating to Mavericks or one of the 10.9.x updates which gave the same symptoms - although I never checked the logs at the time as unticking the box quickly fixed it.

    I assumed it was now default for this to be on because of the new power nap feature of the latest portable Macs.

    The noise of the optical drive and fans starting up make it annoying however on a desktop so I expected to just be able to turn it off again with Yosemite so far no luck however.

    ----------

    Thanks for saving me the time and effort of doing a clean install that wouldn't have worked. Just reported it myself via the feedback page for what it is worth.
     
  10. rpaloalto macrumors 6502a

    rpaloalto

    Joined:
    Sep 19, 2005
    Location:
    Palo Alto CA.
    #10
    Same issue with my early 2008 Mac pro.
    Rtc alarm wakes the Mac pro every 2 hours.

    I did a clean erase and install. No other software installed at this point. I rest smc and pram. Wake for Ethernet is disabled and all sharing possibilitys are also off. I even tried disconnecting from Icloud including my Ethernet cable.

    I'll be going back to Mavericks for now. I have a feeling apple won't be fixing this one. :(
     
  11. Goldfinger macrumors 6502

    Joined:
    Jan 7, 2006
    Location:
    Belgium
    #11
    I filed another bug report fwiw. Here's to hoping this gets fixed in 10.10.1.
     
  12. Mattww macrumors 6502

    Mattww

    Joined:
    Jan 11, 2008
    #12
    I tested overnight will all application quit and it did the same so definitely looks like an OS bug.

    For those who have submitted it already is there a number to quote?
     
  13. Mattww macrumors 6502

    Mattww

    Joined:
    Jan 11, 2008
    #13
    Anyone tried this potential fix and any downsides?

    http://ispire.me/fix-yosemite-rtc-alarm-wakeup-issue/
     
  14. LincolnsiPod macrumors 6502a

    Joined:
    Nov 20, 2009
    #14
    Interesting, I have the same issue, though my wakeup times have been more erratic (Early 2013 MBP). Today it woke up after a 4 hour, 3 hour and 2 hour intervals. All RTC Alarm wakes too. Disabling both PowerNap and Wakeup for Wifi didn't have an effect.

    I had these disabled for my power adapter though, so tonight I'l try disabling for battery as well (even though it's on an adapter) and see what happens. I also didn't have any issues on Mavericks.
     
  15. jaberwocky, Oct 21, 2014
    Last edited: Oct 22, 2014

    jaberwocky macrumors member

    Joined:
    Mar 16, 2009
    Location:
    Europe
    #15
  16. Mitch Pollock macrumors newbie

    Joined:
    Oct 18, 2014
    Location:
    Somewhere in mainland Europe
    #16
    I tried to apply that, and it bloody disabled my Internet access on wi-fi. Not good enough, must try harder. :)
     
  17. LincolnsiPod macrumors 6502a

    Joined:
    Nov 20, 2009
    #17
    Update: disabling power nap on battery mode didn't work either. So weird. I wish I knew what app/process exactly was causing the wakeups. Is there no way to determine what triggers an RTC Alarm wakeup?
     
  18. Mitch Pollock macrumors newbie

    Joined:
    Oct 18, 2014
    Location:
    Somewhere in mainland Europe
    #18
    I've been advised to turn off putting the HDD to sleep when possible. Tomorrow 5:00 am WEST, I'll let you know whether this has had any effect.
     
  19. Mattww macrumors 6502

    Mattww

    Joined:
    Jan 11, 2008
    #19
    I don't think it will as I always have this setting off myself. Also it seems to be due to a network discovery process based on the above fix (that causes it's own problems).
     
  20. Mitch Pollock, Oct 22, 2014
    Last edited: Oct 22, 2014

    Mitch Pollock macrumors newbie

    Joined:
    Oct 18, 2014
    Location:
    Somewhere in mainland Europe
    #20
    I don't expect it to be a working solution, either. I'm just a bit desperate and my Mac's getting tired, so any attempt for a feasible resolution needs to be made. :)

    Anyway, if the network activity proves to be the cause, then it should suffice to turn off the wi-fi and pull out the ethernet cable before putting the Mac to sleep. What about that? I'll give it a try as well if nobody else does.

    UPDATE: As expected, didn't care about that. I'm turning off wi-fi for the next several hours to see how the Mac reacts to it.
     
  21. Mitch Pollock macrumors newbie

    Joined:
    Oct 18, 2014
    Location:
    Somewhere in mainland Europe
    #21
    OK, tried to switch off HDD sleep, tried to switch off wi-fi… nothing works. I'm out of ideas.
     

    Attached Files:

  22. three macrumors 65816

    three

    Joined:
    Jan 22, 2008
    Location:
    Washington State
    #22
    I'm really glad that I'm not the only one with this issue. It wakes up every two hours at 2 minutes past the hour. I've resorted to shutting down the machine at night until this is fixed...
     
  23. Mattww macrumors 6502

    Mattww

    Joined:
    Jan 11, 2008
    #23
    It does seem to be a bug in the new discoveryd process. One suggested work around I've not myself tried yet is unloading the kext before sleep and reloading manually on wake.

    See this thread:

    https://discussions.apple.com/message/26932872?ac_cid=tw123456#26932872
     
  24. phobox macrumors member

    Joined:
    Dec 25, 2007
    #24
    This issue is indeed caused by the discoveryd process which is responsible for dns resolution and Apple's Bonjour network discovery. I fixed it by using the old mDNSResponder from Mavericks, which Ive been running fine on Yosemite with no side effects.

    Complete info and instructions for those a little confused by all this:
    http://apple.stackexchange.com/a/151569
     
  25. Mitch Pollock, Oct 25, 2014
    Last edited: Oct 25, 2014

    Mitch Pollock macrumors newbie

    Joined:
    Oct 18, 2014
    Location:
    Somewhere in mainland Europe
    #25
    Is the discoveryd process active even when the Mac is not physically connected to any network whatsoever? Makes little sense to me, unfortunately…

    Update: When I unload discoveryd and load mDNSResponder, I irreparably lose connection to the Internet. I don't understand what I might be doing wrong… but I cannot apply the fix due to this.
     

Share This Page