Wake Reason: ?

Discussion in 'MacBook Pro' started by tayloj6, Nov 2, 2014.

  1. tayloj6 macrumors newbie

    Joined:
    Nov 2, 2014
    #1
    I am having an issue where my computer will not actually sleep. It goes to sleep and instantly wakes up. I have seen many posts with this issue but none of them seem to help. I am running Yosemite on a Mid 2009 MBP. Everything is stock except I added some RAM.

    The main thing I have noticed that is unique is that in the console right after the computer sleeps I get an event
    11/1/14 10:17:14.000 PM kernel[0]: Wake reason: ?

    So it seems to go to sleep but then instantly wake up. Any help would be huge. This started happening on Mavericks and upgrading to Yosemite didn't change anything. I have tried SMC and PRAM resets.

    Here is a cut from the console. Hope that helps.

    Code:
    11/1/14 10:16:54.000 PM kernel[0]: hibernate_page_list_setall(preflight 1) start 0xffffff80d1376000, 0xffffff80d13b5000
    11/1/14 10:16:55.000 PM kernel[0]: hibernate_page_list_setall time: 325 ms
    11/1/14 10:16:55.000 PM kernel[0]: pages 1006483, wire 144701, act 343647, inact 2602, cleaned 0 spec 7, zf 3135, throt 0, compr 0, xpmapped 40000
    11/1/14 10:16:55.000 PM kernel[0]: could discard act 162340 inact 71531 purgeable 41193 spec 237327 cleaned 0
    11/1/14 10:16:55.000 PM kernel[0]: WARNING: hibernate_page_list_setall skipped 16139 xpmapped pages
    11/1/14 10:16:55.000 PM kernel[0]: hibernate_page_list_setall preflight pageCount 494092 est comp 43 setfile 947912704 min 4294967296
    11/1/14 10:16:55.000 PM kernel[0]: [0x2f8c80c000, 0x32000000]
    11/1/14 10:16:55.000 PM kernel[0]: [0x338480a000, 0x40000000]
    11/1/14 10:16:55.000 PM kernel[0]: [0x33c480a000, 0x40000000]
    11/1/14 10:16:55.000 PM kernel[0]: [0x340480a000, 0x2f000000]
    11/1/14 10:16:55.000 PM kernel[0]: [0x344cf06000, 0x1f000000]
    11/1/14 10:16:55.000 PM kernel[0]: [0x0, 0x0]
    11/1/14 10:16:55.000 PM kernel[0]: kern_open_file_for_direct_io(0) took 0 ms
    11/1/14 10:16:55.000 PM kernel[0]: Opened file /var/vm/sleepimage, size 4294967296, partition base 0x0, maxio 2000000 ssd 0
    11/1/14 10:16:55.000 PM kernel[0]: hibernate image major 1, minor 0, blocksize 4096, pollers 5
    11/1/14 10:16:55.000 PM kernel[0]: hibernate_alloc_pages act 547180, inact 77268, anon 3733, throt 0, spec 237335, wire 144771, wireinit 72990
    11/1/14 10:16:55.000 PM kernel[0]: hibernate_setup(0) took 0 ms
    11/1/14 10:16:55.000 PM kernel[0]: 00000000  00000020  NVEthernet::setLinkStatus - not Active
    11/1/14 10:16:55.431 PM discoveryd[48]: Basic DNSResolver UDNS Send(): UDP Sendto() failed to DNSNameServer 10.0.1.1 Port 53 errno 50, fd 40, ErrLogCount 1 ResolverIntf:5
    11/1/14 10:16:55.431 PM discoveryd[48]: Basic DNSResolver UDNS Send(): UDP Sendto() failed to DNSNameServer 10.0.1.1 Port 53 errno 50, fd 38, ErrLogCount 2 ResolverIntf:5
    11/1/14 10:17:14.000 PM kernel[0]: hibernate_page_list_setall(preflight 0) start 0xffffff80d1376000, 0xffffff80d13b5000
    11/1/14 10:17:14.000 PM kernel[0]: hibernate_page_list_setall time: 389 ms
    11/1/14 10:17:14.000 PM kernel[0]: pages 1008711, wire 146446, act 384117, inact 2605, cleaned 0 spec 7, zf 3135, throt 0, compr 0, xpmapped 40000
    11/1/14 10:17:14.000 PM kernel[0]: could discard act 122340 inact 71529 purgeable 41205 spec 237327 cleaned 0
    11/1/14 10:17:14.000 PM kernel[0]: WARNING: hibernate_page_list_setall skipped 16159 xpmapped pages
    11/1/14 10:17:14.000 PM kernel[0]: hibernate_page_list_setall found pageCount 536310
    11/1/14 10:17:14.000 PM kernel[0]: IOHibernatePollerOpen, ml_get_interrupts_enabled 0
    11/1/14 10:17:14.000 PM kernel[0]: IOHibernatePollerOpen(0)
    11/1/14 10:17:14.000 PM kernel[0]: encryptStart 14040
    11/1/14 10:17:14.000 PM kernel[0]: bitmap_size 0x3e054, previewSize 0x2fc7e0, writing 534288 pages @ 0x34e874
    11/1/14 10:17:14.000 PM kernel[0]: encryptEnd 874ec00
    11/1/14 10:17:14.000 PM kernel[0]: image1Size 0xe884000, encryptStart1 0x14040, End1 0x874ec00
    11/1/14 10:17:14.000 PM kernel[0]: encryptStart e884000
    11/1/14 10:17:14.000 PM kernel[0]: encryptEnd 39db0e00
    11/1/14 10:17:14.000 PM kernel[0]: PMStats: Hibernate write took 18213 ms
    11/1/14 10:17:14.000 PM kernel[0]: all time: 18213 ms, comp bytes: 2188742656 time: 2586 ms 807 Mb/s, crypt bytes: 868645312 time: 5312 ms 155 Mb/s, 
    11/1/14 10:17:14.000 PM kernel[0]: image 970657792 (22%), uncompressed 2188742656 (534361), compressed 962989408 (43%), sum1 61c6f7b5, sum2 420386e2
    11/1/14 10:17:14.000 PM kernel[0]: zeroPageCount 45605, wiredPagesEncrypted 75480, wiredPagesClear 69017, dirtyPagesEncrypted 389864
    11/1/14 10:17:14.000 PM kernel[0]: hibernate_write_image done(0)
    11/1/14 10:17:14.000 PM kernel[0]: sleep
    11/1/14 10:17:14.000 PM kernel[0]: Wake reason: ?
    11/1/14 10:17:14.838 PM discoveryd[48]: Basic DNSResolver UDNS Send(): UDP Sendto() failed to DNSNameServer 10.0.1.1 Port 53 errno 50, fd 38, ErrLogCount 3 ResolverIntf:5
    11/1/14 10:17:14.838 PM discoveryd[48]: Basic DNSResolver UDNS Send(): UDP Sendto() failed to DNSNameServer 10.0.1.1 Port 53 errno 50, fd 38, ErrLogCount 4 ResolverIntf:5
    11/1/14 10:17:14.838 PM discoveryd[48]: Basic DNSResolver UDNS Send(): UDP Sendto() failed to DNSNameServer 10.0.1.1 Port 53 errno 50, fd 38, ErrLogCount 5 ResolverIntf:5
    11/1/14 10:17:14.839 PM discoveryd[48]: Basic DNSResolver UDNS Send(): UDP Sendto() failed to DNSNameServer 10.0.1.1 Port 53 errno 50, fd 38, ErrLogCount 6 ResolverIntf:5
    11/1/14 10:17:17.000 PM kernel[0]: AirPort_Brcm43xx::powerChange: System Wake - Full Wake/ Dark Wake / Maintenance wake
    11/1/14 10:17:17.000 PM kernel[0]: Previous sleep cause: 5
    
     
  2. tayloj6 thread starter macrumors newbie

    Joined:
    Nov 2, 2014
    #3
    I have tried all these solutions and more. I don't have sharing on and it happens regardless of what user I am logged in on and even in safe mode.

    Thanks for the help. Any other ideas?

    ----------

    Additionally, the system will not shut Down without holding the power button. If I shutdown using any other methods the computer always restarts.
     
  3. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #4
    Hmmm... that is really odd. Once it restarts can you look in Console log and scroll back to the exact time of the shutdown to see if the logs give you any clues to what might be going on?
     
  4. tayloj6 thread starter macrumors newbie

    Joined:
    Nov 2, 2014
    #5
    Previous sleep cause

    The latest confusion is such:

    My mac, along along with never shutting down does not properly sleep so it just runs the battery dead. When I let this happen and look in the console I get the following message when I plug it in and boot back up.

    The interesting thing about this is the Previous Sleep Cause -60. Scouring the web shows nothing for this sleep cause. Any thoughts?


    Code:
    11/21/14 9:19:29.000 PM kernel[0]: hibernate_page_list_setall(preflight 0) start 0xffffff80ce854000, 0xffffff80ce893000
    11/21/14 9:19:29.000 PM kernel[0]: hibernate_page_list_setall time: 651 ms
    11/21/14 9:19:29.000 PM kernel[0]: pages 1717659, wire 177029, act 738041, inact 77, cleaned 0 spec 1993, zf 135868, throt 0, compr 12137, xpmapped 40000
    11/21/14 9:19:29.000 PM kernel[0]: could discard act 129781 inact 371551 purgeable 28 spec 149193 cleaned 1961
    11/21/14 9:19:29.000 PM kernel[0]: WARNING: hibernate_page_list_setall skipped 22199 xpmapped pages
    11/21/14 9:19:29.000 PM kernel[0]: hibernate_page_list_setall found pageCount 1065145
    11/21/14 9:19:29.000 PM kernel[0]: IOHibernatePollerOpen, ml_get_interrupts_enabled 0
    11/21/14 9:19:29.000 PM kernel[0]: IOHibernatePollerOpen(0)
    11/21/14 9:19:29.000 PM kernel[0]: encryptStart 14060
    11/21/14 9:19:29.000 PM kernel[0]: bitmap_size 0x3e054, previewSize 0x2bf5f8, writing 1063184 pages @ 0x3116ac
    11/21/14 9:19:29.000 PM kernel[0]: booter start at 4447 ms smc 0 ms, [0, 0, 0] total 6662 ms, dsply 0, 35 ms, tramp 884 ms
    11/21/14 9:19:29.000 PM kernel[0]: hibernate_machine_init: state 2, image pages 175845, sum was 5b1c57e5, imageSize 0x9330b000, image1Size 0x1314a000, conflictCount 1704, nextFree 66d
    11/21/14 9:19:29.000 PM kernel[0]: hibernate_page_list_discard time: 472 ms, discarded act 129781 inact 371551 purgeable 28 spec 149193 cleaned 1961
    11/21/14 9:19:29.000 PM kernel[0]: hibernate_newruntime_map time: 0 ms, IOHibernatePollerOpen(), ml_get_interrupts_enabled 0
    11/21/14 9:19:29.000 PM kernel[0]: IOHibernatePollerOpen(0) 84 ms
    11/21/14 9:19:29.000 PM kernel[0]: hibernate_machine_init reading
    11/21/14 9:19:29.000 PM kernel[0]: PMStats: Hibernate read took 39865 ms
    11/21/14 9:19:29.000 PM kernel[0]: hibernate_machine_init pagesDone 1063961 sum2 dc3b82ac, time: 39865 ms, disk(0x20000) 51 Mb/s, comp bytes: 2548015104 time: 3075 ms 790 Mb/s, crypt bytes: 2149322752 time: 12366 ms 165 Mb/s
    11/21/14 9:19:29.000 PM kernel[0]: Wake reason: (User)
    11/21/14 9:19:29.000 PM kernel[0]: AirPort_Brcm43xx::powerChange: System Wake - Full Wake/ Dark Wake / Maintenance wake
    11/21/14 9:19:29.000 PM kernel[0]: Previous sleep cause: -60
    11/21/14 9:19:29.000 PM kernel[0]: Previous shutdown cause: -60
    
     
  5. tayloj6 thread starter macrumors newbie

    Joined:
    Nov 2, 2014
    #6
    SOLUTION: RAM issues

    I think I have got it fixed. I noticed that my RAM was only showing half of what it should 4GB vs 8GB. I took the RAM out reseated it and now I have 8GB of RAM available again and everything seems to be working better. Sleep and shutdown seem to work correct now as well. I think perhaps an issue with the RAM was preventing the proper shutdown and sleep sequences.

    Makes sense from my simple perspective. Thanks for the help!
     

Share This Page