Become a MacRumors Supporter for $25/year with no ads, private forums, and more!
  • Did you order new AirTags? We've opened a dedicated AirTags forum.

cosmic68

macrumors 6502
Original poster
Dec 26, 2007
487
111
I know Walkie Talkie is a bit flakey at best of times but I’ve noticed some odd behaviour that’s specific to me/my watch and was wondering if anyone experienced similar?

My partner and I both have AW and are on same carriers for iPhone and obviously use same WiFi at home.

If he initiates the walkie talkie session, I get the notification instantly and we can chat straight away.

If I initiate it, it spins for awhile, I get the connection error message, then if I try to reconnect from that point, I get through instantly. Every damn time. This is the same if I try to contact anyone else/any friends also with walkie talkie. My watch always fails on first attempt.

I’ve also noticed, that if I put my iPhone into airplane mode so watch is connected to WiFi on its own (or cellular) and initiate a walkie talkie session-I get through instantly. So something about via iPhone is blocking the first attempt.

I understand that walkie talkie is FaceTime based tech? But obviously just audio. I’ve tried deleting the FaceTime app from iPhone and reinstalling it. I’ve gone nuclear and set AW as new, but no luck.

Anyone able to help/advise?
 

cosmic68

macrumors 6502
Original poster
Dec 26, 2007
487
111
I have exactly the same problem as you. Still searching for a solution.

Yup, I never got this fixed. I’m thinking when I get my next iPhone I’ll set it up as new and see if that makes a difference 🤷🏻‍♂️
 
Comment

firedept

macrumors 603
Jul 8, 2011
6,081
955
Somewhere!
Walkie talkie is hit and miss for my wife and I. Messaging or phone works when walkie is being stubborn. My belief is where you are located. At work I have good spots and bad spots. At home same.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.