Walkie Talkie Not Working

Discussion in 'Apple Watch' started by guywoodman7, Sep 18, 2018.

  1. guywoodman7 macrumors member

    Joined:
    Jan 28, 2008
    Location:
    New York
    #1
    Hey All,

    Anyone run into an issue where you invite someone to walkie talkies but they never get it? Myself and my buddy have apple watches that are capable of using walkie talkies, both are on the latest iOS/WatchOS but neither of us are able to accept invites, or even view them.
     
  2. jamesarm97 macrumors 65816

    Joined:
    Sep 29, 2006
  3. iLoveMyApple macrumors 6502a

    iLoveMyApple

    Joined:
    Oct 26, 2008
    Location:
    Southern California
    #3
    Yep. Same here. My sister invited me and I invited her, but both just say invited with no option on either end to accept. We both have Series 3 models.
     
  4. porkrind macrumors regular

    porkrind

    Joined:
    Jun 30, 2015
    #4
    Had the same problem with my wife last night. We both restarted our phones this morning and after some time, my invite finally went through and everything started working fine.
     
  5. hexagenia macrumors regular

    hexagenia

    Joined:
    Jan 12, 2007
    Location:
    New Hampshire
    #5
    Make sure you both have FaceTime installed on your iPhones, as Walkie Talkie functionality depends upon it being installed to function. If FaceTime is there, try unpairing and repairing. This latter step worked for me. Good luck!
     
  6. Itouch newbie macrumors newbie

    Joined:
    Nov 5, 2009
    #6
    Not working for me either. Both my friend and I have Apple watch 3, both have face time, i cloud logged in etc. First I get a message stating that the user needs have have an apple watch. Doesn't make sense.
     
  7. Sanlitun macrumors 6502

    Sanlitun

    Joined:
    Sep 19, 2014
    Location:
    127.0.0.1
  8. jun180 macrumors regular

    jun180

    Joined:
    Apr 27, 2010
    #8
    Same issue. Managed to accept invitation from my wife, so we are connected. Whenever we try to use it, it just shows connecting but does not send the message. Sometimes get an error saying the connection failed.

    It just works...
     
  9. menace3 macrumors 6502a

    menace3

    Joined:
    Aug 13, 2008
    Location:
    Seattle, WA
    #9
    Got it to work for me. I initially tried an invite and that did not work. then I received an invite as a notification. Once I accepted that, it worked. It should worked directly through the app itself, but only worked once i received and accepted the notificationo n the watch itself.
     
  10. jamesarm97 macrumors 65816

    Joined:
    Sep 29, 2006
    #10
    Friend had to delete his invite to me then re-add it and it worked. For some reason it seemed like both of us inviting each other at the same time broke it.
     
  11. tgara macrumors 6502a

    tgara

    Joined:
    Jul 17, 2012
    Location:
    Connecticut, USA
    #11
    Anyone know why some of the names in the Contact list for Walkie-Talkie are greyed out? I want to connect with my wife who has a Series 3 Apple Watch, but is not yet on WatchOS 5. I suppose I will have to upgrade her watch OS to 5 in order to connect?
     
  12. highertechnology macrumors 6502a

    Joined:
    Jul 31, 2009
    #12
    This is correct. Walkie talkie is a watch OS 5 feature.
     
  13. Bigdog9586 macrumors 6502

    Joined:
    Apr 15, 2015
    #13
    I think at this time it has a lot of work. I can text faster. Touch the talk button, wait for it to connect then push and hold to talk. Since the talk takes the whole screen why not devise the screen. One side touch and release to turn on and other side turn back off after speaking.
     
  14. redman042 macrumors 68030

    redman042

    Joined:
    Jun 13, 2008
    #14
    I’m finding it very buggy so far, to the point of bogging down the OS after a glitch. I just corrected an issue I found so we’ll see if it does better tomorrow. When adding my wife it kept pulling in another contact (former coworker). Turned out they had the same work number in my contacts. Once I removed the duplicate phone number, the other person dropped off my walker talkie contact list.

    Seems like the app is not able to fully distinguish iMessage linked phone numbers from ones that aren’t.

    I have a Series 4 on the way that might run this better, or perhaps it needs a patch.
     
  15. MY_USERNAME macrumors newbie

    MY_USERNAME

    Joined:
    Dec 21, 2017
    #15
    I’m having the same issue :( While were on it there should be a watch face with the talk button front and center.
     
  16. djjohnson macrumors member

    djjohnson

    Joined:
    Jun 26, 2013
    Location:
    Chicago, IL
    #16
    The following steps helped resolve the problem:
    1) Make sure FaceTime is linked/associated to/with iCloud and not just the mobile number. This should be on both ends, as in, the person that you are trying to connect to and yourself.
    2) Delete and reinstall FaceTime on iPhone and this will prompt the Apple Watch to install it.
    3) Reboot both the units and try sending out the invitation.

    Once I did this, it seemed to work!
     
  17. verdejt macrumors 6502

    verdejt

    Joined:
    Jul 19, 2011
    Location:
    Central Florida
    #17
    After quite a bit of fiddling around finally got it to work between my wife and I. I was about 40 minutes into getting really aggravated before I remembered the FaceTime part of it. After that a couple of restarts on both watches and phones and it started working. Haven't had a chance to really test it out yet.
     
  18. tomtattoo macrumors regular

    tomtattoo

    Joined:
    Mar 8, 2013
    Location:
    Berlin
    #18
    Your instruction helped me alot! Thanks for that!
     
  19. dhoerl macrumors newbie

    Joined:
    Oct 13, 2010
    #19
    OK, I finally got it to work and think I know what was wrong - Contact info.

    1) I deleted the invites that were pending by using the Phone, WalkieTalkie App, Edit, then delete. Both Phones.

    2) On both sides, go to Contacts, look at the other persons info, and insure that their phone has a label of "iPhone", not "mobile" or some other such thing. For the email address, make sure its "iCloud", and not some other tag. In addition, just to be sure, I changed the address for <me>@mac.com to <me>@icloud.com - just in case.

    3) Then I told Siri on the Watch, "FaceTime <My Wife's Name"". Insured that I could call her this way. Ditto on her watch to me. This now worked.

    4) Invited her on my watch, she immediately got the invite, accepted, and we could now go forward!
     

Share This Page

18 September 18, 2018