Wallpaper changes to the default one after some time...!

Discussion in 'macOS' started by tatineni, Nov 5, 2009.

  1. tatineni macrumors newbie

    Joined:
    Mar 15, 2009
    #1
    Hi
    Can any one suggest a solution to this problem

    My walpaper changes to the default one .. after some time though i choose a different one.

    What could be the problem..


    Thanks
     
  2. jdsolo macrumors newbie

    Joined:
    Apr 6, 2008
    #2
    just got SL today. having the same issue as well. any help would be appreciated
     
  3. mysterytramp macrumors 65816

    mysterytramp

    Joined:
    Jul 17, 2008
    Location:
    Maryland
    #3
    In System Preferences > Desktop & Screen Saver > Desktop, is "Change Picture:" set?

    mt
     
  4. jdsolo macrumors newbie

    Joined:
    Apr 6, 2008
    #4
    Do you mean click the box that says "Change picture"?

    If I click, I have to choose when I want the picture changed (i.e every 5 sec, 30 min, day etc). There's no option of keeping the same picture.
     
  5. mysterytramp macrumors 65816

    mysterytramp

    Joined:
    Jul 17, 2008
    Location:
    Maryland
    #5
    I was asking if it was set, which could be the root of your problem. Sounds like it wasn't.

    mt
     
  6. jdsolo macrumors newbie

    Joined:
    Apr 6, 2008
  7. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #7
    You're asking the wrong question. For the problem you're having, turning that option on would only make the problem worse.

    As for the root cause, this one's a bit baffling. I've never seen an issue like this before. Some troubleshooting steps to try:
    1. Can you open the image you're trying to use as a desktop background in Preview? If not, the image is corrupted.
    2. Is the folder the image is located in readable to the system? Check the permissions from the Get Info window, if you suspect this might not be the case.
    3. Something might be screwed up elsewhere - say, you have a bad preference file.
     
  8. jdsolo macrumors newbie

    Joined:
    Apr 6, 2008
    #8
    1. yah the image isn't corrupted. it happens with any and every picture. it just changes back to the blank blue wallpaper.
    2. The file is in iPhoto that I personally took.
    3. Not sure how to fix a bad preference file.

    I appreciate the help guys. Please keep them coming. Havent figured it out yet.
     
  9. jdsolo macrumors newbie

    Joined:
    Apr 6, 2008
    #9
    If you have the same problem I was, here's a possible solution:

    You probably have EarthDesk installed. You have to uninstall it. If you cant, just redownload the program from Apple and then uninstall it after you reinstall it. Worked for me. Thanks guys.
     
  10. calderone macrumors 68040

    calderone

    Joined:
    Aug 28, 2009
    Location:
    Seattle
    #10
    Try this:

    1. Navigate to ~/Library/Preferences (the ~ is short for your user folder)
    2. Rename com.apple.desktop.plist to something like com.apple.desktop.plist.test or com.apple.desktop.plist.bad
    3. Logout and Log back in
    4. Your background should now be the default
    5. Set your new background using the file you used before
    6. Wait and see if it happens again
    7. If it doesn't, just trash the old plist
    8. If it does, report back

    A question. When you select this photo in System Preferences, are you selecting from within your iPhoto Library? If so, there may be a problem with SL and the PathIsIphoto key. Hopefully it is simply a corrupt plist.

    Edit: I see you have found the issue. I will leave this in the event that the OP doesn't have this installed.
     

Share This Page