Wanting to unlock/jailbreak Iphone 3g...

Discussion in 'Jailbreaks and iOS Hacks' started by losteboye, Mar 30, 2011.

  1. losteboye, Mar 30, 2011
    Last edited: Mar 30, 2011

    losteboye macrumors newbie

    losteboye

    Joined:
    Mar 30, 2011
    Location:
    Nampa, ID
    #1
    So,

    I bought my Iphone 3g from a friend about a year ago, and he helped me jailbreak/unlock it.

    I want to bump up to the new OS, but I can't find anything that has a good step by step on how to utilize it, was wondering what advice people have on previous jailbreaks they've used? I've seen redsn0w, and multiple others out there.

    My other question is. I'm not really interested in jailbreak apps, more interested in just having my iphone unlocked so that I can utilize it with T-mobile, which is what I'm on right now (waiting for the next gen iphone to come out, then I'll switch to verizon).

    Is it possible to just switch to the 4.1/4.2 os, and just unlock the phone? I've never really touched Cydia on my phone currently.

    Any advice you have would be much appreciated!

    BTW, baseband is 05.11.07 :)
     
  2. Crystal-RX, Mar 30, 2011
    Last edited: Mar 30, 2011

    Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #2
    3G with IOS 4..x is running very slow. I think you are better of with keeping 3.1.2 on yours now.

    In addition, if you don't have SHSH blob save (you need to check), you can't upgrade to the latest firmware while preserve your baseband.
     
  3. jdminpdx macrumors 6502

    Joined:
    Sep 28, 2010
    #3
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_0 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8A293 Safari/6531.22.7)

    Good luck OP. I'd like to know how the most recent FW for the 3G performs for you. My buddy has a 3G and it's very slow.
     
  4. eastercat macrumors 68040

    eastercat

    Joined:
    Mar 3, 2008
    Location:
    PDX
    #4
    IIRC, bb preservation through blobs only work for iPhone 4. For the OP to preserve the bb and upgrade, s/he needs pwnage or its equivalent. The blobs allow the OP to install something other than 4.3.
    D/l tiny umbrella and see if it saves any blobs earlier than 4.3.

     
  5. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #5
    For 3G, any firmware above 4 need a blob to upgrade. You can downgrade 3G to a 3.x.x without any problem and just need to fix a 1015 error.

    The latest firmware for 3G is 4.2.1. So, OP can upgrade his/her to this latest firmware by using pwnage and preserve the baseband.
     

Share This Page