Warcraft 3 + FT install problems...

Discussion in 'Mac and PC Games' started by Devie, Jun 2, 2007.

  1. Devie macrumors 6502a

    Joined:
    Aug 30, 2004
    Location:
    Adelaide, Australia
    #1
    Heyage.

    I have a major problem with the installation of this game, it all installs and informs me of a correct installation... but I try to get into the game and it just crashes instantly.
    It use to work when I had the game installed before hand, though my HDD and Logic board shagged itself and I never bothered re-installing the game (just got to into WoW). Now that I've quit WoW, I still want to play WCIII!!!

    As far as I know, there is nothing wrong with my GPU, as I can still play Halo CE Demo (D/L'd it just to test the GPU).

    I have attempted to delete every possible file associating itself with Warcraft with no luck... even unistalled WoW.

    Any ideas? Thanks in advance!


    EDIT: Just to add, the game works fine on a PC. (its a hybrid disc)
     
  2. Chone macrumors 65816

    Chone

    Joined:
    Aug 11, 2006
    #2
    Have you tried applying the latest patch? I know you have an iMac G5 so it SHOULD work even without the 1.21 UB patch but maybe patching will solve whatever issue is plaguing your OSX install?

    Also, install Frozen Throne BEFORE patching the game to 1.21 otherwise all will go to hell and god will murder AT LEAST 1 or 2 kitties.
     
  3. Devie thread starter macrumors 6502a

    Joined:
    Aug 30, 2004
    Location:
    Adelaide, Australia
    #3
    Yeah tried all that...

    I went to disc utility the other day and said theres something that needs to be repaired but I can't repair it... the button isn't activated I can just diagnose it? How do I fix that?? I'm guessing it may be related...
     

Share This Page