Warcraft 3, MBP, Windows XP: Crash on Options

Discussion in 'Mac and PC Games' started by jeff^d, Dec 12, 2007.

  1. jeff^d macrumors member

    Joined:
    Nov 8, 2007
    #1
    I'm running Warcraft 3 Reign of Chaos on a SR MBP 2.4/256 in Windows XP Pro. The game seems to run and play fine, but any time I try to go into Options from the main menu, it crashes and gives me a FATAL ERROR message. I can post the error if it'd be helpful.

    I have used the default Boot Camp video drivers, as well as several different versions of laptopvideo2go drivers, all yield the same problem. I can play all other games fine, and like I said, I can play WC3 I just can't change the options. The game functions fine in OS X. Any ideas? Anyone seen this problem before?
     
  2. haiggy macrumors 65816

    Joined:
    Aug 20, 2003
    Location:
    Ontario, Canada
    #2
    I don't know, but it used to happen to me too in Tiger on my iBook. I assume reinstalling should fix it.
     
  3. Maclarny macrumors 6502

    Maclarny

    Joined:
    Apr 20, 2003
    Location:
    MN
    #3
    Doing the following solved a similar problem for me on OSX:

    Find the preferences/settings information for Warcraft 3 and delete it. Next time you run you'll start up with default settings, but everything should be back to working normally.
     
  4. haiggy macrumors 65816

    Joined:
    Aug 20, 2003
    Location:
    Ontario, Canada
    #4
    I'm pretty sure when I did that it was only a temporary fix and I started encountering issues again later on.
     
  5. GodfatherOS macrumors newbie

    Joined:
    Jun 13, 2008
    #5
    I know this is an old thread, but can some1 pls help me ASAP!!! How do I find the preferences/settings information for WC3??? What am I looking for?
     
  6. KingYaba macrumors 68040

    KingYaba

    Joined:
    Aug 7, 2005
    Location:
    Up the irons
    #6
    If you're on the Mac, from the Finder go to User - Library - Preferences and look for "Warcraft III Preferences"
     

    Attached Files:

  7. bballwigga macrumors newbie

    Joined:
    Oct 20, 2008
    #7
    i also have had this problem but only after i had updated the software... (i'm using OSX by the way)

    my graphics also became much worse and even when i trashed the preferences folder they still didn't improve and i still couldn't access the options menu.

    Very annoying

    Help?
     
  8. imassents macrumors 6502

    Joined:
    Jul 3, 2008
    #8
    To show you it is a preference issue, go to System Preferences -> Accounts

    Temporarily create yourself a new account for testing purposes
    Log into it and load up Warcraft - the Options screen should work

    The reason this will work is because a new user account has no preferences set.

    To fix your other account, you must delete all references to Blizzard, Warcraft and Battle.net from your preferences folder. Use spotlight to help search the preferences folder for files with these terms in their name.

    Off the top of my head they are some of the following files
    com.Blizzard.WarcraftIII.20
    com.Blizzard.WarcraftIII.21
    com.Blizzard.WarcraftIII
    Warcraft III Preferences
    Battle.net Preferences

    You may or may not have all these, and there may be more. Be very thorough in your search - all of them will be recreated when needed.

    Also, the OP in this post has this issue under Windows XP - it's totally different again. He has something messed up in the registry.
     

Share This Page