Warcraft III and missing OpenGL

goodtimes5

macrumors 6502a
Original poster
Apr 4, 2004
778
0
Bay Area
I've been playing Warcraft III on my MBP for a year. Yesterday my Warcraft III failed to open anymore and gave this error message: "Warcraft III was unable to initialize OpenGL. Please ensure you have OpenGL installed and that your display drivers are current." I haven't changed anything about my computer.

The only problem I can think of is that I recently set Warcraft to use my external monitor instead of the MBP's in the game preferences. My external monitor is in a different city now, and Warcraft won't load.
 

goodtimes5

macrumors 6502a
Original poster
Apr 4, 2004
778
0
Bay Area
Through a series of reinstalls, I've come to the conclusion that the 1.0 versions load and work just fine. After patches, I get the OpenGL error messages. Any help?
 

nthpro

macrumors newbie
Mar 12, 2008
3
0
Go to /Users/(username)/Library/Preferences/

Delete
com.blizzard.Warcraft III.prefs
com.blizzard.WarcraftIII
com.blizzard.BNUpdate

and restart and you should have your problem fixed! Good luck!
 

BugX

macrumors newbie
Feb 12, 2009
2
0
Raising up a very old thread..
Actually, I've found this thread from google... But Dude... You're Rock!!

Thx..

Go to /Users/(username)/Library/Preferences/

Delete
com.blizzard.Warcraft III.prefs
com.blizzard.WarcraftIII
com.blizzard.BNUpdate

and restart and you should have your problem fixed! Good luck!
 

pjelvis22

macrumors newbie
Apr 9, 2018
1
0
Go to /Users/(username)/Library/Preferences/

Delete
com.blizzard.Warcraft III.prefs
com.blizzard.WarcraftIII
com.blizzard.BNUpdate

and restart and you should have your problem fixed! Good luck!
i don't have any of the above in preferences. i don't know what else to do..
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.