Warcraft III, LAN, and Windows XP -- oh my

Discussion in 'Mac and PC Games' started by verviana, Mar 21, 2009.

  1. verviana macrumors newbie

    Jul 21, 2007
    Heidi ho neighbors...

    So here's my story.

    I'm trying to play Warcraft III over LAN (i.e.--NOT through Battle.net) and despite much research and effort we can't see each other within the game.

    He is running Windows XP and I am running Leopard. We are both running the same patch of the game. We CAN share files quite effectively--I've got his drive mounted and he's got mine as a Network Place. Firewalls are off. We've both tried re-installing and re-updating. Etc.

    Anyone have any suggestions?
  2. imassents macrumors 6502

    Jul 3, 2008
    While I know you said the firewalls are off, 9 times out of 10 this issue is caused by a software firewall of some sort (different firewalls can have undesired affects when turned off, and still block ports). What firewalls are you using on the computers? OS X has it's builtin firewall as does XP, are there any others running?

    Check the firewall in XP by going to Start->Control Panel->Firewall. There is a tick box here that enables/disables exceptions. Make sure it is allowing exceptions. Click the Exceptions tab. Remove the war3.exe entry and re-add it (add program). When that is created, click add port and type in 6112 with TCP (name can be anything).

    With the OS X firewall, set it to allow all incoming connections (System Preferences->Security->Firewall). The other options do not play nice with Warcraft.

    Also, how are the computers connected to each other? LAN cables to a switch/router or is one wireless?
  3. verviana thread starter macrumors newbie

    Jul 21, 2007

    It was indeed a firewall problem--basically, my friend needed to turn Windows Firewall off entirely in order to get it to work. "Allow All Incoming Connections" just wasn't cutting it!

    Thank you for pointing us in the right direction. :)

Share This Page